php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23066 fsocketopen fail when connecting to server where calling script run
Submitted: 2003-04-05 16:18 UTC Modified: 2003-04-06 12:15 UTC
From: garfield_fr at tiscali dot fr Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: garfield_fr at tiscali dot fr
New email:
PHP Version: OS:

 

 [2003-04-05 16:18 UTC] garfield_fr at tiscali dot fr
Config :
OS : Win2000
Server HTTP : IIS5
PHP 4.3.1 ISAPI

I have 2 scripts : client.php and server.php on a server.
I can use these scripts by http://mysite.domain.net/server.php and http://mysite.domain.net/client.php.

In fact, client.php is a test script to check server.php, a web services using nuSOAP. both scripts are using nuSOAP.php.

1/ When client.php run on server and call server.php with URL : http://mysite.domain.net/server.php I have a fsockopen error:
[05-Apr-2003 22:15:10] PHP Warning:  fsockopen() [<a href='http://www.php.net/function.fsockopen'>function.fsockopen</a>]: php_hostconnect: connect failed in E:\wwwwRoot\mysite\nuSOAP\nusoap.php on line 1352
[05-Apr-2003 22:15:10] PHP Warning:  fsockopen() [<a href='http://www.php.net/function.fsockopen'>function.fsockopen</a>]: unable to connect to mysite.domain.net:80 in E:\wwwwRoot\mysite\nuSOAP\nusoap.php on line 1352

2/ When I use my computer to run client.php (running at http://10.0.0.11/client.php where 10.0.0.11 is my local IP) and call server.php at http://mysite.domain.net/server.php I have a good result and evry thing work fine.

3/ When I use my computer to run client.php (running at http://10.0.0.11/client.php where 10.0.0.11 is my local IP) and call server.php at http://10.0.0.11/server.php I have a good result and evry thing work fine too !!!

From 1/ and 2/ I think fsockopen() can't open a connection on the server who run the calling scripts (remember, it's in ISAPI mode)...so maybe a bug here ?

but from why 3/ work ? my local server is in ISAPI mode to (IIS5/W2K Pro SP3)...

conclusion : fsockopen seem to fail in some case .... I think is a bug ???

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-05 20:18 UTC] pollita@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


This is *impossible* to debug without knowing the contents of client.php and server.php.
 [2003-04-06 06:10 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

A lot of bugs have been fixed since 4.3.1 in this snapshot
(regarding socket stuff)


 [2003-04-06 11:48 UTC] garfield_fr at tiscali dot fr
After lot of test with my Admin network, I found the "bug" is due to a config "anti spoofing" on server ....
So it's not a bug !!!!

sorry, I close the report....
 [2003-04-06 12:15 UTC] pollita@php.net
Non Bug == Bogus
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 06:01:23 2020 UTC