php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2302 odbc_execute does not seem to call SQLBindParameter
Submitted: 1999-09-15 06:33 UTC Modified: 2002-06-16 08:40 UTC
From: havardpe at fast dot no Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 3.0.11 OS: Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: havardpe at fast dot no
New email:
PHP Version: OS:

 

 [1999-09-15 06:33 UTC] havardpe at fast dot no
Here is the code segment that gives me problems:
(simplified)

$conn_id = odbc_connect($db_name, $user, $pass);
$stmt = odbc_prepare($conn_id, "INSERT INTO
          table (value1, value2) VALUES (?, ?)");
$data = array('test1', 'test2');

odbc_execute($stmt, &$data);


When using an Oracle database server, this produces the following error message:

Warning: SQL error: [Oracle][ODBC Oracle Driver]SQLBindParameter has not been called for parameter #2., SQL state 07001 in SQLExecute in ...

I tried to use Access first, and got the same error (07001).
I cannot find any other ways to bind my parameters than to rely on the odbc_execute function to to this.

NOTE: if I insert the SQL parameter values directly into the SQL statement it works fine, but I need to pass them separate from the query to avoid quoting problems.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-28 11:55 UTC] kara at cvs dot php dot net
Does this also happen with 3.0.12?
 [1999-11-29 09:31 UTC] havardpe at fast dot no
Bug #2704 looks like the same problem only with 3.0.12
 [2002-06-16 08:40 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 08:01:25 2020 UTC