php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23013 Wrong variables registered from POST / GET
Submitted: 2003-04-02 04:24 UTC Modified: 2003-04-02 10:41 UTC
From: bugs dot php dot net at doller dot dk Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.3.1 OS: SunOS webserver1 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs dot php dot net at doller dot dk
New email:
PHP Version: OS:

 

 [2003-04-02 04:24 UTC] bugs dot php dot net at doller dot dk
When posting etc. the following from a form:

mod = "ret_kode"
username = "admin"
password1 = "admin"
password2 = "admin"

My $_POST array looks like this:

$_POST["mod"] = "ret_kode"
$_POST["username"] = "admin"
$_POST["password1"] = "admin"
$_POST["password2"] = "admin"

But since I have register_globals = "on", I should be able to get the variables without using $_POST, but the variables look like this:

$mod = "ret_kode&username=admin&password1=admin&password2=admin"
$username = "admin"
$password1 = "admin"
$password2 = "admin"

In version 4.2.3 there's no problem, but as I upgraded to 4.3.1 the problem came...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-02 04:35 UTC] bugs dot php dot net at doller dot dk
I down-graded to 4.2.3 so now I don't have the problem anymore, but thank's anyway.

Just wanted to report it... :)
 [2003-04-02 04:43 UTC] moriyoshi@php.net
This should be fixed in 4.3.2.
(Maybe dupe of bug #22733)
 [2003-04-02 05:52 UTC] magnus@php.net
Requested feedback.
 [2003-04-02 05:55 UTC] sniper@php.net
This was already fixed in CVS.

 [2003-04-02 10:41 UTC] moriyoshi@php.net
oops, dupe of bug #22773

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 20 19:01:33 2024 UTC