php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22982 interbase freeresult does not work (missing parameter)
Submitted: 2003-03-31 09:12 UTC Modified: 2003-03-31 13:57 UTC
From: dbadmin at avenet dot stw dot uni-erlangen dot de Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.3.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dbadmin at avenet dot stw dot uni-erlangen dot de
New email:
PHP Version: OS:

 

 [2003-03-31 09:12 UTC] dbadmin at avenet dot stw dot uni-erlangen dot de
It seems that in the file 

  pear/DB/ibase.php


a parameter is missing for the 

  function freeResult()

therfore an error occurs when calling  $result->free:

Notice: Undefined variable: result in /usr/share/pear/DB/ibase.php on line 211

when chaning the function to

function freeResult($result)

everything works fine.
in the other db-files eg. mysql.php this parameter $result is available.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-31 13:57 UTC] mj@php.net
Please get the latest version of DB from http://pear.php.net/. The problem is already fixed there.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 11:01:28 2024 UTC