php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22921 PHP EXE crashes with "could not read memory"
Submitted: 2003-03-27 05:03 UTC Modified: 2003-03-31 17:02 UTC
From: tohlow at novadys dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.2RC1 OS: win 2k
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tohlow at novadys dot com
New email:
PHP Version: OS:

 

 [2003-03-27 05:03 UTC] tohlow at novadys dot com
I know this is a pain in the neck, because there already is a couple of entries similar to this BUT I hope I can provide some extra info.

I am developing a DCOM based PHP application and have just tried with 4.32 RC1. PHP.EXE simply crashes, apparently when clearing up its object tables (when PHP.EXE unloads from memory, it seems to try to clear up too many object references, unfortunately I cannot be more specific because I am no C++ developper). Actually, we had been in contact with Harald Radi before and he found the problem, fixed it for PHP 4.23, but it got back in in release 4.30 :(

In RC1 now, it crashes, same for all releases between 4.30 and 4.32 and 4.10 and 4.22.

One additional problem is, that in the only working release (4.23), when clearing up the object references, apparently NOT all are being cleared up, resulting in kept alive objects which - as a consequence in my case - don't free the licenses to our DCOM server :(
The only PHP version that I found that BOTH does NOT crash AND frees ALL references correctly is 4.06.

One last hint: 4.31 crashes BUT correctly frees the references...

Hope this is not all too confusing and that there will be a fix in the final release of 4.32, it would be greatly appreciated by a lot of people, I think, definetly by myself!
Thanks, T

P.S.: It seems to be the same for IIS and Apache...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-28 12:50 UTC] phanto@php.net
could you please provide a simple script to reproduce that. the problem is known with 4.3.0 and 4.3.1 but should be fixed since then.

ps: magnus, please stop acting snotty like jani
 [2003-03-31 03:04 UTC] tohlow at novadys dot com
Hi guys,

I am REALLY sorry about this, I do need to apologise: Everything is working fine in RC1!
Thanks for nudging to the sample script, as regards the crash, there was a problem with the custom COM server we use when using enumeration objects, this did not crash in PHP 4.23, but after... Apology for this!

As regards the unfreed COM reference, this is working fine as well, the problem was an uncleared subreference to this particular object...

Lads, sorry again and thanks a million for your fast reaction and help: I am looking very forward to 4.32!
T
 [2003-03-31 17:02 UTC] phanto@php.net
closing.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 09:03:49 2022 UTC