php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22917 Crashing Exhibit Engine Mysql Backup Omni
Submitted: 2003-03-26 22:44 UTC Modified: 2003-04-28 11:14 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mail at artmosher dot ca Assigned:
Status: No Feedback Package: MySQL related
PHP Version: 4.3.2-RC OS: windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mail at artmosher dot ca
New email:
PHP Version: OS:

 

 [2003-03-26 22:44 UTC] mail at artmosher dot ca
Using Windows 98SE AMD450 128MB 60GB Mysql 3.23.47
Omnihttpd server (http://www.omnicron.ca)
Running App Exhibit Engine (http://photography-on-the.net/ee/) V1.3

When running the app's Utility-Backup DB to File function an immediate crash of PHP 4.3.1 occurs.  Detail shows error in php4ts.dll
This function worked flawlessly in PHP last version used 4.2.2
At this time I am unable to backup !!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-28 15:31 UTC] mail at artmosher dot ca
OK.  The CVS below did NOT solve the problem.  Continues to crash immediately upon EE Backup.  Nuts & Bolts Bomb Shelter crash protector program that I run shows:

PHP caused an invalid page fault in
module PHP4TS.DLL at 0257:1000f29d.
Registers:
EAX=00d39004 CS=0257 EIP=1000f29d EFLGS=00010206
EBX=00d162b8 SS=025f ESP=0063f0a0 EBP=00d16788
ECX=00000001 DS=025f ESI=00d39004 FS=6d47
EDX=0063f0dc ES=025f EDI=0000000b GS=0000
Bytes at CS:EIP:
8b 4e 38 b8 01 00 00 00 c1 ef 02 23 f8 89 44 24 
Stack dump:
00762470 00762470 00d16788 00d162b8 00000001 10011444 00d39004 0000000b 00762470 00d158f8 100c2f43 00d158f8 00762470 00000000 007634d8 0076de10 

Any other thoughts ??
 [2003-03-29 10:27 UTC] mail at artmosher dot ca
Possible INI problem ???  Here's the INI :

http://us.f1.yahoofs.com/users/79935ce2/bc/bugdata/php.ini?bcOych.AvER.gNK2
 [2003-04-02 10:28 UTC] sniper@php.net
Are you 100% sure you really updated to the latest CVS snapshot? In about 99% of these cases, people just haven't
updated EVERY single file from the new package..
Most important one being php4ts.dll.

 [2003-04-02 16:53 UTC] mail at artmosher dot ca
Yes - I'm sure I have 4.3.2  !!
I typically Rename c:\php to c:\phpyyyymmdd
and then create a new PHP directory and UnZip or copy php files to it.
The current php4ts.dll is from folder

http://uk.briefcase.yahoo.com/bc/artm9/vwp2?.tok=bcYo2VRBe5XKLGlm&.dir=/bugdata&.dnm=php4tsXplore.jpg&.src=bc

and shows version

http://uk.briefcase.yahoo.com/bc/artm9/vwp2?.tok=bcYo2VRBCdstyna8&.dir=/bugdata&.dnm=php4ts.dll.jpg&.src=bc
 [2003-04-23 04:30 UTC] sniper@php.net
Please provide a short, complete and self-contained example
script that can be used to reproduce this problem.

 [2003-04-28 11:14 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 04:03:36 2021 UTC