php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22896 Error on make with 4.3.1 on solaris 8
Submitted: 2003-03-26 07:23 UTC Modified: 2003-04-21 09:19 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:2 (50.0%)
From: jpt at ifrance dot com Assigned:
Status: No Feedback Package: Sybase-ct (ctlib) related
PHP Version: 4.3.1 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jpt at ifrance dot com
New email:
PHP Version: OS:

 

 [2003-03-26 07:23 UTC] jpt at ifrance dot com
Hello,
When i build php 4.3.2 with Apache 1.3.25 on a Solaris 8 system i have this output after the make:
Undefined                       first referenced
 symbol                             in file
intl_datetime                       /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intlgetenv                          /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_iocsfclose                     /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_open                           /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intl_nextvalue                      /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intl_iocsfgets                      /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
comn_free                           /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
comn_realloc                        /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_strbuild                       /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_iocsfwrite                     /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_iocsfopen                      /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_close                          /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intl_iocsfread                      /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
comn_calloc                         /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_home                           /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_nextsection                    /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intl_iocsfseek                      /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_nextentry                      /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
intl_cstrbuild                      /opt/sybase-12.5/OCS-12_5/lib/libcs.so
comn_malloc                         /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
intl_errstr                         /opt/sybase-12.5/OCS-12_5/lib/libcomn.so
ld: fatal: Symbol referencing errors. No output written to sapi/cli/php
collect2: ld returned 1 exit status
*** Error code 1make: Fatal error: Command fail

Any idee please !

thanks


ed for target `sapi/cli/php'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-26 07:25 UTC] jpt at ifrance dot com
(The untruncated msg )
*** Error code 1make: Fatal error: Command failed for target `sapi/cli/php'
 [2003-04-08 03:14 UTC] tim at comben dot com
I have a very simmilar problem on Solaris version 9.0, when i try to add in the apxs module it stops with a simmilar error report.
tim
 [2003-04-09 05:53 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

And what was the configure line for PHP you used?

 [2003-04-21 09:19 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-08-09 16:35 UTC] trollcollect at yahoo dot de
Same here. Tried with 4.3.8, the problem appears exactly when sybase support (DB or CT) is added in configure. To narrow the problem down i tried with this configure line:

./configure --prefix=/export/apps/apache-RAtool/php --with-apxs=/export/apps/apache-RAtool/apache/1.3.31/bin/apxs --disable-all --with-sybase-ct=/apps/sybase/12/OCS-12_0/

...same problem. The system is a fairly recent solaris 8, i've tried with both gcc 3.3.2 and newest workshop compiler. Trying to link against several Sybase versions between 11 and 12.0. Found a few people report this error over the net, without a single helpful answer yet. 

Latest and most desperate attempt was to build 5.0.0 hoping it would not show these errors, no success though. Here are the relevant lines of the make output:
o Zend/zend_reflection_api.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/
getopt.lo main/internal_functions_cli.lo -linsck -ltcl -lintl -lcomn -lct -lcs -
lresolv -lm -ldl -lnsl -lsocket -lgcc  -o sapi/cli/php
Undefined                       first referenced
 symbol                             in file
intl_iocsfgets                      /apps/sybase/12/OCS-12_0//lib/libtcl.so
intlgetenv                          /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_close                          /apps/sybase/12/OCS-12_0//lib/libcomn.so
intl_iocsfseek                      /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_strbuild                       /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_home                           /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_iocsfclose                     /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_cstrbuild                      /apps/sybase/12/OCS-12_0//lib/libcs.so
intl_nextentry                      /apps/sybase/12/OCS-12_0//lib/libcomn.so
comn_calloc                         /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_iocsfopen                      /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_open                           /apps/sybase/12/OCS-12_0//lib/libcomn.so
intl_nextvalue                      /apps/sybase/12/OCS-12_0//lib/libcomn.so
comn_realloc                        /apps/sybase/12/OCS-12_0//lib/libtcl.so
comn_free                           /apps/sybase/12/OCS-12_0//lib/libtcl.so
comn_malloc                         /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_iocsfread                      /apps/sybase/12/OCS-12_0//lib/libcomn.so
intl_nextsection                    /apps/sybase/12/OCS-12_0//lib/libcomn.so
intl_iocsfwrite                     /apps/sybase/12/OCS-12_0//lib/libtcl.so
intl_datetime                       /apps/sybase/12/OCS-12_0//lib/libcomn.so
intl_errstr                         /apps/sybase/12/OCS-12_0//lib/libcomn.so
ld: fatal: Symbol referencing errors. No output written to sapi/cli/php
collect2: ld returned 1 exit status
gmake: *** [sapi/cli/php] Error 1
 [2004-08-12 12:02 UTC] trollcollect at yahoo dot de
Just fyi, we have made progress on this. It seems the problem arises from a "broken" libintl within solaris that php links against. To solve this, the sybase client brings his own libintl_r but this is not being used by the generated makefile for php. So after running configure, modify the Makefile from -lintl to -lintl_r.

Another problem was the "forced" usage of the sybtcl library which i also had to remove / modify from -lsybtcl to -ltcl.

HTH
 [2006-05-16 18:47 UTC] elegua at hotmail dot com
I have Solaris 8, Apache 2.0, and PHP 5.1.4. I am trying to configure --with-sybase-ct= for sybase 12-5. I get the exact same errors. I have searched the Web and I have tried various types of things as everyone else has listed, but with no luck. 

This works

./configure --prefix=/export/home/php --with-apxs2=/export/home/apache/bin/apxs --with-libxml=/opt/csw/lib --with-zlib-dir=/opt/csw/lib --with-mysql=/export/home/mysql --with-mysqli=/export/home/mysql/bin/mysql_config --with-gd --enable-soap --enable-sockets --with-sybase=/export/home/sybase/

This does not

./configure --prefix=/export/home/php --with-apxs2=/export/home/apache/bin/apxs --with-libxml=/opt/csw/lib --with-zlib-dir=/opt/csw/lib --with-mysql=/export/home/mysql --with-mysqli=/export/home/mysql/bin/mysql_config --with-gd --enable-soap --enable-sockets --with-sybase-ct=/export/home/sybase/

The sybase that is installed has a symlink from OCS_12-5 to the standard /sybase/lib. 

I am not sure why the sybase build works, and the -CT does not. The reason I am trying to use -ct is because I cannot get results from stored procedures. Nothing I have found on the net says that going to the ct library will fix this. But I cannot find anything else that gives me any hope of being able to get results ( and not the value of 1 ) from my stored procedures. 

Thanks.. :( any help would be much appreciated!!
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 15:01:28 2024 UTC