php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22854 ibase_query complains that number of read/write doesn't equal count values
Submitted: 2003-03-24 11:16 UTC Modified: 2003-08-20 18:25 UTC
From: al2925 at mail dot ru Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.3.0 OS: Windows 2000 Server SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: al2925 at mail dot ru
New email:
PHP Version: OS:

 

 [2003-03-24 11:16 UTC] al2925 at mail dot ru
I get such warning:

PHP Warning:  ibase_query(): Dynamic SQL Error SQL error code = -804 Count of read-write columns does not equal count of values  in c:\gentle\php_includes\IbaseConnection.php(86) : runtime-created function on line 1

The query looks like 

ibase_query($link, 'INSERT INTO tableName (cols, ..) VALUES (cols, ?, ?, ?)', $blob0, $blob1, $blob2);

All parameters are BLOBs. This happens only if the count of parameters is more than one. I'm running Firebird Superserver for Windows version 1.0.2.908 The error began to occur after I upgraded from PHP 4.3.2 

Please, feel free to contact me via e-mail. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-31 01:59 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-08-20 18:25 UTC] abies@php.net
As the query string is passed untouched to the Interbase client library, the error is either in the string (which I suspect is the case) or in Interbase itself. 

My guess is that simply the (number of fields) != (number of values + placeholders)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 31 07:01:24 2020 UTC