php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22853 phpinfo() builds invalid XHTML code
Submitted: 2003-03-24 11:05 UTC Modified: 2003-03-24 18:43 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: rabus at users dot sourceforge dot net Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5CVS-2003-03-24 (dev) OS: Red Hat Linux 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rabus at users dot sourceforge dot net
New email:
PHP Version: OS:

 

 [2003-03-24 11:05 UTC] rabus at users dot sourceforge dot net
I know, this is a rather small bug, but nevertheless php should go with W3C's specifications imho.

I compiled php as Apache 2 module.
When calling my phpinfo() script, the generated HTML code contains the following line:

<h2><a name="module_Apache 2.0">Apache 2.0</a></h2>

W3C's HTML validator bothers about this line and says, 'value of attribute "name" must be a single token'.
As far as I can see, the problem is the whitespace between "module_Apache" and "2.0".

Happy fixing :-)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-24 18:43 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 03:04:04 2022 UTC