php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22851 configure stops at "checking whether IMAP works... no"
Submitted: 2003-03-24 10:12 UTC Modified: 2003-03-25 08:40 UTC
From: davidp at oak dot njit dot edu Assigned:
Status: Closed Package: IMAP related
PHP Version: 4.3.1 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: davidp at oak dot njit dot edu
New email:
PHP Version: OS:

 

 [2003-03-24 10:12 UTC] davidp at oak dot njit dot edu
#!/bin/ksh

set -o allexport

PATH=/usr/local/bin/gnu:$PATH
DIR=/afs/cad/solaris/apache.127.proto

if [[ -d $DIR/php-4.3.1 ]]; then
 cd $DIR/php-4.3.1
else
 print "$DIR/php-4.3.1 does not exist -- exiting..."
 exit 0
fi

./configure \
--with-apxs=$DIR/apache/bin/apxs \
--with-ldap=/afs/cad/solaris/openldap \
--with-imap=/usr/local/imap \
--with-imap-ssl=/usr/local/ssl \
| tee -a CONFIGURE.log

#--------------------------
=> Configure stops at:
checking whether IMAP works... no
configure: error: build test failed. Please check the config.log for details.

=> From config.log:
configure:35446: gcc -o conftest -g -O2  -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=2
80 -DUSE_EXPAT  -R/usr/ucblib -L/usr/ucblib -R/usr/local/lib/gcc-lib/sparc-sun-s
olaris2.8/3.2 -L/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.2 -R/usr/local/imaplib -L/usr/local/imaplib -R/usr/local/ssl/lib -L/usr/local/ssllib conftest.c
 -lcrypto -lssl -lc-client   -lcrypt -lpam -lcrypt -lresolv -lm -ldl -lnsl -lsoc
ket  -lgcc -lcrypt 1>&5
Undefined                       first referenced
 symbol                             in file
SSL_library_init                    /usr/local/imap/lib/libc-client.a(osdep.o)
.
.

ERR_get_error                       /usr/local/imap/lib/libc-client.a(osdep.o)
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure: failed program was:
#line 35421 "configure"
#--------------------------
=> End of CONFIGURE.log:

checking for IMAP support... yes
checking for pam_start in -lpam... yes
checking for crypt in -lcrypt... (cached) yes
checking whether SSL libraries are needed for c-client... /usr/local/ssl/lib
checking whether IMAP works... no
#--------------------------
/usr/local/imap/lib/libc-client.a is from Univ. of Washington IMAP
imap-2003.DEV.SNAP-0301171021

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-25 08:33 UTC] davidp at oak dot njit dot edu
Your suggestion to use 
 http://snaps.php.net/php4-STABLE-latest.tar.gz
fixed the IMAP problem ! Thanks !
 [2003-03-25 08:40 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

User reports that the problem has been fixed in latest CVS.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 08:03:18 2022 UTC