php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22793 failed to create stream: Too many open files
Submitted: 2003-03-19 17:23 UTC Modified: 2003-03-19 17:27 UTC
From: ewa at buffalo dot edu Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.3.1 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ewa at buffalo dot edu
New email:
PHP Version: OS:

 

 [2003-03-19 17:23 UTC] ewa at buffalo dot edu
We have an apache webserver with 291 virtual hosts. Recently upgraded from: apache1.3.26+ssl_1.48/openssl-0.9.6e/php4.2.3 to

apache1.3.27+ssl_1.48/openssl-0.9.7a/php4.3.1

We are experiencing intermittant problems with webpages not loading. Reloading a page fixes it sometimes and sometimes it does not. The problem goes away after apache server is restarted and the problem does not show up until 3 or 4 days later.  

the errors we get:

Warning: main(admissions_navigation.inc) [function.main                       
<http://www.php.net/function.main>]: failed to create stream: Too many open   
files in /info/www/ubwww/admissions/index.php on line 13                      
                                                                              
Warning: main() [function.main <http://www.php.net/function.main>]: Failed    
opening 'admissions_navigation.inc' for inclusion                             
(include_path='.:/usr/local/lib/php') in                                      
/info/www/ubwww/admissions/index.php on line 13                               
                                                                              
Warning: main(admissions_page.inc) [function.main                             
<http://www.php.net/function.main>]: failed to create stream: Too many open   
files in /info/www/ubwww/admissions/index.php on line 14                      
                                                                              
Warning: main() [function.main <http://www.php.net/function.main>]: Failed    
opening 'admissions_page.inc' for inclusion                                   
(include_path='.:/usr/local/lib/php') in                                      
/info/www/ubwww/admissions/index.php on line 14                               
                                                                              
Warning: main(classes/CONFIG/log_config.inc) [function.main                   
<http://www.php.net/function.main>]: failed to create stream: Too many open   
files in /info/www/ubwww/admissions/index.php on line 15                      
                                                                              
Warning: main() [function.main <http://www.php.net/function.main>]: Failed    
opening 'classes/CONFIG/log_config.inc' for inclusion                         
(include_path='.:/usr/local/lib/php') in                                      
/info/www/ubwww/admissions/index.php on line 15                               

Any thoughts appreciated.
Thanks in advance,
Ewa

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-19 17:27 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 17:01:31 2024 UTC