php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22718 sablot and zziplib won't config together
Submitted: 2003-03-14 18:10 UTC Modified: 2003-03-14 19:07 UTC
From: deverrors at graphicon dot biz Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.1 OS: redhat 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: deverrors at graphicon dot biz
New email:
PHP Version: OS:

 

 [2003-03-14 18:10 UTC] deverrors at graphicon dot biz
this problem is very similar to... 
http://bugs.php.net/bug.php?id=21466

only based on my compile options, it has nothing to do with pdf (i'm not installing it). i personally think it is sablot that changes something that then causes zip to crap out. take a look and see if it is php related.

versions...
redhat 8.0 full install (all libraries)
php-4.3.1
apache_1.3.27
expat-1.95.5 (expat-1.95.6 doesn't work with Sablot yet)
sablot-0.97
zziplib-0.10.75 (same error when used with 0.11.15 or 0.10.27)
kernel-smp-2.4.18-24.8.0

the problem config...
./configure --with-apache=../apache_1.3.27 --enable-xslt --with-xslt-sablot --with-zip

both these configs work fine...
./configure --with-apache=../apache_1.3.27 --enable-xslt --with-xslt-sablot

./configure --with-apache=../apache_1.3.27 --with-zip


the probelm config causes config.log excerpt below

configure:71260: checking whether to enable XML support
configure:71306: checking external libexpat install dir
configure:71951: checking for XMLRPC-EPI support
configure:71997: checking libexpat dir for XMLRPC-EPI
configure:72022: checking iconv dir for XMLRPC-EPI
configure:73484: checking whether to enable xslt support
configure:73530: checking for XSLT Sablotron backend
configure:73555: checking for libexpat dir for Sablotron XSL support
configure:73580: checking for iconv dir for Sablotron XSL support
configure:73605: checking for JavaScript for Sablotron XSL support
configure:73859: checking for Sablotron libraries in the default path
configure:73875: checking for sablot-config
configure:73893: checking for Sablotron version
configure:73918: gcc -o conftest -g -O2  -I/usr/local/include  conftest.c -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
cc1: warning: changing search order for system directory "/usr/local/include"
cc1: warning:   as it has already been specified as a non-system directory
configure:74093: checking for iconv
configure:74121: gcc -o conftest -g -O2   -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lexpat -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
configure:74652: checking for SablotSetEncoding in -lsablot
configure:74671: gcc -o conftest -g -O2
      -L/usr/local/lib
      -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lsablot  -lexpat -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
/usr/local/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete(void*)'
/usr/local/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
/usr/local/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete[](void*)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
configure: failed program was:
#line 74660 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char SablotSetEncoding();

int main() {
SablotSetEncoding()
; return 0; }
configure:74705: checking for SablotGetOptions in -lsablot
configure:74724: gcc -o conftest -g -O2   -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lsablot  -lexpat -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
/usr/local/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete(void*)'
/usr/local/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
/usr/local/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete[](void*)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
configure: failed program was:
#line 74713 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char SablotGetOptions();

int main() {
SablotGetOptions()
; return 0; }
configure:74894: checking for YAZ support
configure:75407: checking whether to include YP support
configure:75875: checking for ZIP support
configure:75941: checking for zzip_open in -lzzip
configure:75960: gcc -o conftest -g -O2
    -L/usr/local/lib
    -Wl,-rpath,/usr/local/lib -L/usr/local/lib conftest.c -lzzip  -lsablot -lexpat -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
/usr/local/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete(void*)'
/usr/local/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
/usr/local/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator delete[](void*)'
/usr/local/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/local/lib/libsablot.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
configure: failed program was:
#line 75949 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char zzip_open();

int main() {
zzip_open()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-14 19:07 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


http://bugs.php.net/bug.php?id=19983

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 02:01:23 2020 UTC