|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22717 Cannot compile using --with-imap-ssl
Submitted: 2003-03-14 17:08 UTC Modified: 2003-03-16 15:26 UTC
From: mage at gmage dot net Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.3.0 OS: Debian Linux 2.4.20
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: mage at gmage dot net
New email:
PHP Version: OS:


 [2003-03-14 17:08 UTC] mage at gmage dot net
I cannot get php (4.3.0 through latest CVS) to compile when using --with-imap-ssl.  I'm using debian linux with the debian libc-client SSL packages installed.  I've seen numerous posts on this problem, but none of the solutions have worked for me.  Configure line as follows:

./configure --prefix=/usr/local \
  --with-apache=/root/programs/Apachetoolbox-1.5.64/apache_1.3.27 \
--enable-exif \
--enable-track-vars \
--with-calendar=shared \
--enable-magic-quotes \
--enable-trans-sid \
--enable-wddx \
--enable-ftp \
--enable-inline-optimization \
--enable-memory-limit \
 --with-imap=/usr/local \
 --with-imap-ssl \
 --with-mhash=/usr/local \
 --with-mcrypt=/usr/local \
 --with-openssl="/usr/local" \
 --with-gettext="/usr" \
 --with-mysql=/usr \

Compiling shows the following error:

ext/imap/php_imap.o(.text+0x345): In function `zm_startup_imap':
/root/programs/Apachetoolbox-1.5.64/src/php-4.3.0/ext/imap/php_imap.c:424: undefined reference to `ssl_onceonlyinit'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

Which I'm sure you've seen before. ;)

As I said, I've tried the latest CVS and it still didn't work.  I also tried compiling my own c-client from imap-2002b and pointing to that as the imap source.  No go.  Any help is appreciated.  -Ken


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-14 19:01 UTC]
Please try using this CVS snapshot:
For Windows:

And I mean THIS snapshot, not any other.
(if you did try the latest STABLE snapshot, from today, then ignore this)

And it seems to me that your c-client just doesn't have SSL support in it..

Try configure _without_ --with-imap-ssl option.

 [2003-03-16 12:56 UTC] mage at gmage dot net
I had already tried the latest-stable CVS as of the date of original post.

It compiles fine w/o the -imap-ssl option, but I'm ONLY running imap over ssl(993) for imp.

Someone had told me that the later c-client libraries don't include the imap-ssl support as the older ones did, is this possibly true?  What is the most tested c-client version for ssl?
 [2003-03-16 15:26 UTC]
If your c-client library is not compiled with SSL support,
of course you can't magically get SSL support into
PHP imap extension by just adding --with-imap-ssl in the configure line. Not bug.

 [2003-03-16 15:26 UTC]
And ask further support questions about compiling c-client/php elsewhere, this is not a support forum.

 [2003-03-21 22:38 UTC] ross at golder dot org
Happens for me too with the 4.3.2RC1 tarball. I tried just '--with-imap', but that told me I had to use '--with-imap-ssl', so I used that too, then got the 'ssl_onceonlyinit' problem described above.

As I cannot find the 'ssl_onceonlyinit' symbol in either the c-client or ssl libraries, I simply commented this line out of ext/imap/php_imap.c. It builds and runs fine for me.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Apr 13 20:01:28 2024 UTC