php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22716 end of make MySQL tempnam is dangerous, better use mkstemp
Submitted: 2003-03-14 16:09 UTC Modified: 2003-03-14 16:28 UTC
From: neuman_peter at hotmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.2RC1 OS: Debian Linux/GNU 3.0r1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: neuman_peter at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-03-14 16:09 UTC] neuman_peter at hotmail dot com
Hello,

I build the PHP-4.3.2RC1 on my test box only with "./configure" and I get this Warning on end "make"

[...]
pt -lresolv -lm -ldl -lnsl -lcrypt -lcrypt  -o sapi/cli/php
ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/home/peter/dev/php/php-4.3.2RC1/ext/mysql/libmysql/my_tempnam.c:103: the use of `tempnam' is dangerous, better use `mkstemp'
$shuttle:

Please use mkstemp, Thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-14 16:28 UTC] georg@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

see #22715
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 12:01:28 2024 UTC