php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22659 set_error_handler("foo") doesn't care if foo exists
Submitted: 2003-03-12 10:13 UTC Modified: 2003-03-12 19:20 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: steil at zweitwerk dot com Assigned:
Status: Wont fix Package: Scripting Engine problem
PHP Version: 4.3.2RC1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
15 + 45 = ?
Subscribe to this entry?

 
 [2003-03-12 10:13 UTC] steil at zweitwerk dot com
What I mean is the following

<?php
    // first call returns nothing
    $ret1 = set_error_handler("unknown_function");
    var_dump($ret1);

    // second call returns "unknown_function"
    $ret2 = set_error_handler("another_unknown_function");
    var_dump($ret2);
?>

The documentation says set_error_handler() would return FALSE if an error occurs. Therefore, both of the above calls should return FALSE since setting the error handler to an unknown function is certainly an error.

As a consequence I am not able to check if the call to set_error_handler() has been successful.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-12 16:59 UTC] sniper@php.net
It returns NULL for me. And this error message:
"Warning - set_error_handler() expects argument 1, 'unknown_function', to be a valid callback"


 [2003-03-12 19:20 UTC] iliaa@php.net
Fixing this problem would require the code to check for the function's existance when set_error_handler() is called. This also would mean that the error handler would need to be declared in the PHP code BEFORE the set_error_handler() tries to set that function as the error handler. This behaviour change would break all of the scripts that declare error_handler AFTER calling set_error_handler();
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 18 19:05:43 2022 UTC