php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22632 '-c' switch on cli produced core dump on cygwin
Submitted: 2003-03-11 05:05 UTC Modified: 2003-03-11 11:10 UTC
From: momo@php.net Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4CVS-2003-03-11 (stable) OS: win2000 cygwin
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: momo@php.net
New email:
PHP Version: OS:

 

 [2003-03-11 05:05 UTC] momo@php.net
where ./php.ini is empty file, doing: php -c ./php.ini, produced: Segmentation fault (core dumped)

the problem is with php5/php4 both with regular ./configure

here is bt:

#0  0x004f632a in ini_parse () at Zend/zend_ini_parser.c:1043
#1  0x004f5fa3 in zend_parse_ini_file (fh=0x22fb10, 
    unbuffered_errors=1 '\001', 
    ini_parser_cb=0x4c714e <php_config_ini_parser_cb>, arg=0x53aba0)
    at /cygdrive/d/php-dev/php4/Zend/zend_ini_parser.y:164
#2  0x004c781b in php_init_config ()
    at /cygdrive/d/php-dev/php4/main/php_ini.c:385
#3  0x004c21a4 in php_module_startup (sf=0x538450, 
    additional_modules=0x0, num_additional_modules=0)
    at /cygdrive/d/php-dev/php4/main/main.c:1163
#4  0x00526259 in main (argc=3, argv=0xa042188)
    at /cygdrive/d/php-dev/php4/sapi/cli/php_cli.c:481

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-11 05:17 UTC] edink@php.net
Which bison version? 1.875? If yes could you try downgrading to 1.75 or 1.28 and rebuilding?
 [2003-03-11 06:08 UTC] momo@php.net
1.75 fixed the problem.

what about check on the configure before closing this bug?
 [2003-03-11 11:10 UTC] sniper@php.net
Use 1.28 and all is fine.
(we recommend it too)

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC