php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22600 No HTTP_*_VARS
Submitted: 2003-03-07 20:49 UTC Modified: 2003-03-08 10:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jonathan at rietta dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5CVS-2003-03-07 (dev) OS: RedHat Linux 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jonathan at rietta dot com
New email:
PHP Version: OS:

 

 [2003-03-07 20:49 UTC] jonathan at rietta dot com
Whenattempting to use the latest version of phpMyAdmin and a PHP snapshot from this morning, I get the following error multiple times:

Notice: Undefined variable: HTTP_SERVER_VARS in /home/blah/public_html/phpMyAdmin/libraries/common.lib.php on line 524

register_globals is on. However, no trace exists of any of the HTTP_*_VARS after writing a test script to verify that.

The following 3-line script, named test.php produces no output when requested by Apache:

<?php
print $HTTP_SERVER_VARS["PHP_SELF"];
?>

I never had this problem in PHP 4.3.0. Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-07 21:32 UTC] jonathan at rietta dot com
variable_order is is set to EGPCS
 [2003-03-08 10:00 UTC] sniper@php.net
Yeah, stick to RELEASES and not to stuff that is under
heavy development. This is not a bug, see php.ini-dist
for "register_long_arrays".

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 12:05:52 2022 UTC