php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22594 sprintf functionality altered from previous version. ?bug
Submitted: 2003-03-07 14:57 UTC Modified: 2003-04-14 22:42 UTC
From: wreetz at greenapple dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.3.1 OS: BSDI 4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wreetz at greenapple dot com
New email:
PHP Version: OS:

 

 [2003-03-07 14:57 UTC] wreetz at greenapple dot com
sprintf in 4.2.1 & 4.3.1 gives different results.

<?PHP 
$s='truncate'; 
echo sprintf(" %8.5s",$s); 
?> 

Results: 
4.2.1: trunc 
4.3.1: truncate 

I Don't know if this is a new bug, an intended change, was a bug in 4.2.1 that's now fixed, or ?

Thanks, 
Wendy

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-07 15:03 UTC] helly@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

The new behavior is the correct one :-))
 [2003-04-14 22:42 UTC] moriyoshi@php.net
The new behaviour is wrong indeed. See bug #22227

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC