|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22591 ftp_rawlist still not working
Submitted: 2003-03-07 09:21 UTC Modified: 2003-03-11 19:41 UTC
From: davidfelton at codemasters dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.1 OS: Windows 2000 Server
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: davidfelton at codemasters dot com
New email:
PHP Version: OS:


 [2003-03-07 09:21 UTC] davidfelton at codemasters dot com
same as bug #16057, which was closed, but shouldn't have been.

ftp_rawlist doesn't work at all on windows server with IIS.
cgi version of PHP.


// Attempt to login to the remote server

//try and use ftp_rawlist
$fileList = ftp_rawlist($con, "/Services/enterprise");//will hang


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-07 11:17 UTC] davidfelton at codemasters dot com
Can you verify that it's not working with 4.3.1 CGI?
 [2003-03-10 10:05 UTC]
Are you sure you tested the latest snapshot? 
Are you sure you installed it correctly?
I just tried it on my win2k machine, and this works just fine for me.

 [2003-03-10 10:14 UTC] davidfelton at codemasters dot com
Yes I downloaded from the link you gave me. phpinfo confirms I am running 4.3.2-dev build 2195 
As far as I can tell it's all installed properley.
You did try with the CGI version?
 [2003-03-10 19:44 UTC]
Yes, with the CGI binary. But from cmd line.
But it shouldn't matter really..

Try it on command line too. So we can be sure it's
strictly under IIS when it doesn't work well..

 [2003-03-11 03:10 UTC] davidfelton at codemasters dot com
I get the same result from the command line. A call to ftp_rawlist hangs until the 30 second timeout is reached.

As a side note, I've tried this on a machine with OmniHTTPd installed and got the same result.
 [2003-03-11 19:41 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

wasn't reproduced, probably due to a end-user misconfiguration.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Jun 04 20:03:40 2023 UTC