php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22591 ftp_rawlist still not working
Submitted: 2003-03-07 09:21 UTC Modified: 2003-03-11 19:41 UTC
From: davidfelton at codemasters dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.1 OS: Windows 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: davidfelton at codemasters dot com
New email:
PHP Version: OS:

 

 [2003-03-07 09:21 UTC] davidfelton at codemasters dot com
same as bug #16057, which was closed, but shouldn't have been.

ftp_rawlist doesn't work at all on windows server with IIS.
cgi version of PHP.

//connect
$con=ftp_connect("ftp.microsoft.com");

// Attempt to login to the remote server
ftp_login($con,"anonymous","someone@somewhere.com");

//try and use ftp_rawlist
$fileList = ftp_rawlist($con, "/Services/enterprise");//will hang

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-07 11:17 UTC] davidfelton at codemasters dot com
Can you verify that it's not working with 4.3.1 CGI?
 [2003-03-10 10:05 UTC] sniper@php.net
Are you sure you tested the latest snapshot? 
Are you sure you installed it correctly?
I just tried it on my win2k machine, and this works just fine for me.

 [2003-03-10 10:14 UTC] davidfelton at codemasters dot com
Yes I downloaded from the link you gave me. phpinfo confirms I am running 4.3.2-dev build 2195 
As far as I can tell it's all installed properley.
You did try with the CGI version?
 [2003-03-10 19:44 UTC] sniper@php.net
Yes, with the CGI binary. But from cmd line.
But it shouldn't matter really..

Try it on command line too. So we can be sure it's
strictly under IIS when it doesn't work well..


 [2003-03-11 03:10 UTC] davidfelton at codemasters dot com
I get the same result from the command line. A call to ftp_rawlist hangs until the 30 second timeout is reached.

As a side note, I've tried this on a machine with OmniHTTPd installed and got the same result.
 [2003-03-11 19:41 UTC] sterling@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

wasn't reproduced, probably due to a end-user misconfiguration.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 03:03:16 2021 UTC