|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22534 Environment Variables not resolved
Submitted: 2003-03-04 06:05 UTC Modified: 2003-03-04 10:39 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: KTalleur at abics dot de Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 4.3.1 OS: SuSE Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
15 - 3 = ?
Subscribe to this entry?

 [2003-03-04 06:05 UTC] KTalleur at abics dot de
I am using PHP 4.3.1 as a CGI with Apache 1.3.27. Using phpinfo(), i found out that the variables


are not shown in the environment section. Therefore, PHP_SELF is shown empty in the PHP Variables section.

With PHP 4.2.2 (same Apache Config, just the php binary changed), everything is fine - the two environment variables are shown, and the php_self variable is set. So this is a feature of the current version!

I compiled PHP with  --enable-track-vars,--enable-force-cgi-redirect, --with-gd=/usr.

Any suggestions?


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-04 07:35 UTC] jeanfrancois dot lecam at altiplano dot fr
I guess my problem is the same :
using apache-1.3.27/suexec + cgiwrap-3.7.1 + php-4.3.1 as a CGI, I get a "premature end of script headers" (used to work with php-4.2.3).
Using cgiwrapd and php.ini with 'log_errors = On', it says :

PHP Fatal error:  Unknown(): Unable to open /home/websites/website1/web/ in Unknown on line 0

This is my doc_root, it lacks the script name !

Downgrading to 4.2.3...
 [2003-03-04 07:38 UTC] KTalleur at abics dot de
No, its not the same. In my environment, the script is executed. I don't get any errors, except for the missing values / variables.
 [2003-03-04 10:39 UTC] KTalleur at abics dot de
It worked with the CMS-Snapshot (linux version).

 [2003-03-31 13:08 UTC] hosting at voodooweb dot com
I have the same problem like "jeanfrancois dot lecam at altiplano dot fr" reported but I don't use cgiwrap just standard apache suexec and FreeBSD 4.5 as OS.
My script worked with 4.2.3 but crashed with 4.3.1 and the CVS-snapshot.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 11:03:36 2021 UTC