php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22480 mod_php randomly displays source instead of script output
Submitted: 2003-02-28 11:43 UTC Modified: 2003-03-09 19:20 UTC
Votes:3
Avg. Score:3.0 ± 1.6
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: kaspars at fabrika dot lv Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.3.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
31 - 29 = ?
Subscribe to this entry?

 
 [2003-02-28 11:43 UTC] kaspars at fabrika dot lv
After upgrade to php 4.3 (and later 4.3.1) I get source of php files instead of their supposed output on a random basis. The site in question - http://economics.sseriga.edu.lv displays source approx. once in 10 tries.

System - Gentoo Linux with all (stable) updates, gentoo patched XFS kernel 2.4.19, apache 1.2.27, compiled with GCC 3.2.1 -march=i686 -O3 -pipe

Compile options:
./configure --prefix=/usr --with-bz2 --enable-ftp --enable-force-cgi-redirect --enable-discard-path --enable-gd-native-ttf --enable-mime-magic --enable-wddx --enable-dbase --with-zlib=yes --with-iconv --enable-bcmath --enable-sysvsem --enable-exif --with-gd --enable-sysvshm --enable-sockets --enable-calendar --enable-trans-sid --enable-safe-mode --enable-versioning --enable-track-vars --enable-inline-optimization --with-config-file-path=/etc/php4 --host=i686-pc-linux-gnu --without-readline --with-pam --with-gettext --with-openssl --with-gdbm=/usr --with-db3=/usr --with-mysql=/usr --with-pgsql=/usr --with-ttf --with-t1lib --with-pdflib=/usr --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-zlib --with-zlib-dir=/usr/lib --with-exec-dir=/usr/bin --with-apxs=/usr/sbin/apxs --with-xml --with-dom --with-mcrypt --with-mhash --disable-posix-threads 

Any ideas? I can provide more info as needed. Any help is much appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-28 13:35 UTC] kaspars at fabrika dot lv
My mistake - it's Apache 1.3.27 of course
 [2003-03-02 21:51 UTC] kaspars at fabrika dot lv
Bug 19292 (http://bugs.php.net/bug.php?id=19292) seems to be causing this odd behavior, since adding "php_admin_value open_basedir none" to Apache virtual hosts' config seems to have 'fixed' the problem.
 [2003-03-09 19:20 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 11:01:26 2021 UTC