php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22471 Getting "inflate" buffer error
Submitted: 2003-02-28 03:23 UTC Modified: 2003-03-05 08:18 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: 4u at direct-netware dot de Assigned:
Status: Closed Package: Zlib related
PHP Version: 4.3.1 OS: WinNT
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 4u at direct-netware dot de
New email:
PHP Version: OS:

 

 [2003-02-28 03:23 UTC] 4u at direct-netware dot de
>>> Description:

>> Error report from the webware:

BOF

direct WebenginE
Your Community Center

Debug File Service (DFS)
If you find a possible bug then please report it here:
http://www.direct-netware.de/redirect.php?we.itracker

VERSION_DATA:
v1.00.a032802 [ALPHA]

SCRIPT_NAME:
dwe.php

GET_DATA:
s=edocs
a=doc
dsd=3e324cb3b93af;3e324cf65be9c
tf=default
lang=de
uuid=ff0c192690c99cfc962b36ffcc18ae29

POST_DATA:

TIMESTART_DATA:
1046423297 - 0.76239000

DFS_DATA:
0.024875 .:. dWE/dwe.php _main_ (267)
0.025251 .:. dWE/system/global/dwe_dbsystem_mysql_basics.php -direct_opendb ()- (43) .:. 0.000617
[...]
0.109956 .:. UMF/system/global/direct_zipfile_functions.php -direct_getzipentry (+zipp,content.xml,0,0,1)- (285)
0.110336 .:. UMF/system/global/direct_zipfile_functions.php -direct_getzipentries (+zipp,0)-File- (171) .:. 0.000953
0.138688 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (114) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.141387 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.147579 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.149777 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.15207 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.156753 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.159024 .:. PHP .:. gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) .:. D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (128) .:. 4.3.1 (WINNT) .:. Debug mode 3 security breach warning
0.111974 .:. UMF/system/global/direct_zipfile_functions.php -direct_getzipdata (s,+zipp,4881,5656,1)- (107) .:. 0.04771
0.160127 .:. UMF/system/global/direct_zipfile_functions.php -direct_closezip (+zipp)- (41)
0.161286 .:. UMF/system/global/direct_basics.php -direct_require (oset/default/global/errors.dwe_oset.php)- (467)
[...]
0.210714 .:. UMF/system/global/direct_basics.php -direct_exit ()- (449)

TIMEEND_DATA:
1046423298 - 0.94910700

REMOTE_DATA:
[...]

EOF

The following lines are causing the above error report:
[Variable names are changed for a better overview)

> Original:

  if ($tcompressed) { $direct_tempdata_1string = gzinflate (@fread ($zipp,$tlength)); }
  else { $direct_tempdata_1string = @fread ($zipp,$tlength); }

> Possible fix (unsuccessful):

  if ($tcompressed)
  {
   $direct_tempdata_1string = "";
   $direct_tempdata_2string = 0;

   do
   {
    if (($tlength - $direct_tempdata_2string) > 999) { $direct_tempdata_3string = 1000; }
    else { $direct_tempdata_3string = ($tlength - $direct_tempdata_2string); }

    $direct_tempdata_2string += $direct_tempdata_3string;
    $direct_tempdata_1string .= gzinflate (@fread ($zipp,$direct_tempdata_2string));
   }
   while ($direct_tempdata_2string < $tlength);
  }
  else { $direct_tempdata_1string = @fread ($zipp,$tlength); }

> Var-Details:
$direct_tempdata_1string = Result string (uncompressed data from a zip archive)
$direct_tempdata_2string = Bytes already read from the archive
$direct_tempdata_3string = Next byte length to read

I tried to reduce the $direct_tempdata_3string down to 100 byte for inflating but still getting the buffer error (2) seen in the report above.

>>> Modules:

Seems to be not required for this bug report

>>> Setup data:

Windows XP
PHP 4.3.1
Apache 2.0.44
MySQL 4.0.9-gamma
Administrative rights: yes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-28 03:28 UTC] 4u at direct-netware dot de
Error in "possible fix script":

Bogus:
$direct_tempdata_1string .= gzinflate (@fread
($zipp,$direct_tempdata_2string));

New:
$direct_tempdata_1string .= gzinflate (@fread
($zipp,$direct_tempdata_3string));

Changing bug description: No
 [2003-02-28 10:58 UTC] 4u at direct-netware dot de
I'm sorry, but the error still exists:

BOF

direct WebenginE
Your Community Center

Debug File Service (DFS)
If you find a possible bug then please report it here:
http://www.direct-netware.de/redirect.php?we.itracker

VERSION_DATA:
v1.00.a032802

SCRIPT_NAME:
dwe.php

GET_DATA:
s=edocs
a=doc
dsd=3e324cb3b93af;3e324cf65be9c
tf=default
lang=de
uuid=4f0baa466f197e8cc53676d8de26a626

POST_DATA:

TIMESTART_DATA:
1046451285 - 0.42326100

DFS_DATA:
0.025231 .:. dWE/dwe.php _main_ (267)
0.025518 .:. dWE/system/global/dwe_dbsystem_mysql_basics.php -direct_opendb ()- (43) .:. 0.00064599999999998
[...]
0.078591 .:. UMF/system/global/direct_zipfile_functions.php -direct_getzipentries (+zipp,0)-File- (153) .:. 0.000801
0.103941 .:. PHP 4.3.2-dev (WINNT): gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) -D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (310)- .:. Debug mode 3 security breach warning
0.135716 .:. PHP 4.3.2-dev (WINNT): gzinflate() [<a href='http://www.php.net/function.gzinflate'>function.gzinflate</a>]: buffer error (2) -D:\Server\data\www8010\docs\system\global\direct_zipfile_functions.php (114)- .:. Debug mode 3 security breach warning
0.10453 .:. UMF/system/global/direct_zipfile_functions.php -direct_getzipdata (s,+zipp,4881,5656,1)- (107) .:. 0.031705
0.136511 .:. UMF/system/global/direct_zipfile_functions.php -direct_closezip (41)
[...]
0.181576 .:. UMF/system/global/direct_basics.php -direct_exit ()- (449)

TIMEEND_DATA:
1046451285 - 0.58036400

REMOTE_DATA:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Detailed data unavailable

EOF
 [2003-02-28 11:53 UTC] 4u at direct-netware dot de
Before someone ask what I'm meaning with the report:
0.117436 .:. FILTERED/system/global/direct_zipfile_functions.php -gzinflate(): buffer error- (310) .:. PHP 4.3.2-dev (WINNT) (Error code: 2)
0.147095 .:. FILTERED/system/global/direct_zipfile_functions.php -gzinflate(): buffer error- (114) .:. PHP 4.3.2-dev (WINNT) (Error code: 2)

(Error format string changed)

Error: gzinflate(): buffer error
Error code: 2
 [2003-03-05 08:18 UTC] 4u at direct-netware dot de
As written here: http://bugs.php.net/bugs.php?id=22546 - bug is only "happening" if there is a wrong data length
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Aug 06 01:01:24 2020 UTC