php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22430 HTML_Template_ITX::placeholderExists() is broken
Submitted: 2003-02-26 06:41 UTC Modified: 2003-03-11 20:31 UTC
From: borz_off at cs dot msu dot su Assigned: pajoye (profile)
Status: Closed Package: PEAR related
PHP Version: 4.2.3 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
37 - 4 = ?
Subscribe to this entry?

 
 [2003-02-26 06:41 UTC] borz_off at cs dot msu dot su
require_once 'HTML/Template/ITX.php';

$tpl = new HTML_Template_ITX();
$tpl->setTemplate('{var}');
// no placeholder {foobar} in template, should return false
if ($tpl->placeholderExists('foobar')) {
    echo 'broken!';
} else {
    echo 'ok!';
}

The script prints 'broken!' instead of 'ok!'.

see also comments to http://bugs.php.net/bug.php?id=18949

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-11 20:31 UTC] pajoye@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 16:03:34 2021 UTC