php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22391 empty result sets returned incorrectly from mssql_execute
Submitted: 2003-02-24 05:28 UTC Modified: 2003-03-06 05:34 UTC
From: php at centaur dot mailshell dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.3.1 OS: Windows XP SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at centaur dot mailshell dot com
New email:
PHP Version: OS:

 

 [2003-02-24 05:28 UTC] php at centaur dot mailshell dot com
Windows XP SP1
MSSQL 2000
Apache 2.0.44
PHP 4.3.1

Procedure definition:
CREATE PROCEDURE foo
  @filter VARCHAR(255)
AS
  SELECT id FROM bar WHERE baz LIKE @filter
GO;

Script:
<?php
$con = mssql_connect('localhost', $user, $password);
mssql_select_db($dbname);
$sp = mssql_init('foo');
mssql_bind($sp, '@filter', $filter, SQLVARCHAR);
$result = mssql_execute($sp);
print "[".$result."]\n"; // point A
while ($row = mssql_fetch_object($result)) {
  // do something with $row
}?>

If there are no records in bar that satisfy $filter, [1] is printed at point A, and then mssql_fetch_object (and other functions that expect a resource ID, e.g. mssql_next_result) fails.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-06 05:02 UTC] php at centaur dot mailshell dot com
Seems fixed.
 [2003-03-06 05:34 UTC] magnus@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

User reports the problem is fixed in snapshot.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 05:05:45 2022 UTC