php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22377 Using COM causes php.exe CGI to crash
Submitted: 2003-02-22 13:45 UTC Modified: 2003-02-23 07:08 UTC
From: bmatzelle at yahoo dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.1 OS: Windows 2000 & XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bmatzelle at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-02-22 13:45 UTC] bmatzelle at yahoo dot com
I created a script like this:

<?php
$adodb = new COM("ADODB.Connection");
?>

Each time I try to load this page I experience a "[snip] Memory could not be read" error with php.exe.  This happens with all COM objects, not just ADODB.Connection.

I have found this error with PHP 4.3.0 and 4.3.1, both using the PHP CGI module. cgi.force_redirect is set to "0".  All other normal pages run without a hitch. I have not changed the php.ini COM defaults in any way.  I do not use any extensions, and I am using the standard win32 binaries from php.net. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-23 07:08 UTC] phanto@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

... and fixed in cvs for a while now.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 00:01:32 2024 UTC