|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22357 exit signal Segmentation fault (11)
Submitted: 2003-02-21 10:54 UTC Modified: 2003-03-09 18:58 UTC
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (66.7%)
From: m dot heidenwolf at ehotel dot ag Assigned:
Status: No Feedback Package: *General Issues
PHP Version: 4.3.2-dev OS: Redhat Linux 2.4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: m dot heidenwolf at ehotel dot ag
New email:
PHP Version: OS:


 [2003-02-21 10:54 UTC] m dot heidenwolf at ehotel dot ag

after a few code changes i get a crash like
 exit signal Segmentation fault (11)
in the apache logs.

The backtrace is:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 20130)]
0x40158e47 in memcpy (dstpp=0x40c5c2cc, srcpp=0x0, len=1076992773) at ../sysdeps/generic/memcpy.c:55
55      ../sysdeps/generic/memcpy.c: No such file or directory.
        in ../sysdeps/generic/memcpy.c
(gdb) bt
#0  0x40158e47 in memcpy (dstpp=0x40c5c2cc, srcpp=0x0, len=1076992773) at ../sysdeps/generic/memcpy.c:55
#1  0x4031a1bd in smart_str_appendl_ex (dest=0xbfff92f0, src=0x0, len=1076992773, what=0) at php_smart_str.h:75
#2  0x4031a471 in php_var_serialize_class_name (buf=0xbfff92f0, struc=0x81d63c0) at var.c:385
#3  0x40319c3e in php_var_serialize_intern (buf=0xbfff92f0, struc=0x81d63c0, var_hash=0xbfff9300) at var.c:519
#4  0x40319d90 in php_var_serialize_intern (buf=0xbfff92f0, struc=0x81ddc5c, var_hash=0xbfff9300) at var.c:557
#5  0x40319df7 in php_var_serialize (buf=0xbfff92f0, struc=0x81ddc5c, var_hash=0xbfff9300) at var.c:571
#6  0x40319e9c in zif_serialize (ht=1, return_value=0x823ef64, this_ptr=0x0, return_value_used=1) at var.c:594
#7  0x40243289 in execute (op_array=0x8576348) at ./zend_execute.c:1598
#8  0x4024349b in execute (op_array=0x81dca44) at ./zend_execute.c:1638
#9  0x40253f90 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at zend.c:812
#10 0x402668be in php_execute_script (primary_file=0xbffff2b0) at main.c:1383
#11 0x4026126e in apache_php_module_main (r=0x8172aac, display_source_mode=0) at sapi_apache.c:90
#12 0x402620dc in send_php (r=0x8172aac, display_source_mode=0,
    filename=0x817493c "/home/marco/htdocs/fastbooking/bedhunter/de/buchung.php") at mod_php4.c:575
#13 0x40262149 in send_parsed_php (r=0x8172aac) at mod_php4.c:590
#14 0x080860af in ap_invoke_handler () at eval.c:41
#15 0x0809b177 in process_request_internal () at eval.c:41
#16 0x0809b1d8 in ap_process_request () at eval.c:41
#17 0x080920b5 in child_main () at eval.c:41
#18 0x08092284 in make_child () at eval.c:41
#19 0x080923f8 in startup_children () at eval.c:41
#20 0x08092a74 in standalone_main () at eval.c:41
#21 0x080932ff in main () at eval.c:41
#22 0x400f1e5e in __libc_start_main (main=0x8092f34 <main>, argc=5, ubp_av=0xbffff6ec, init=0x804fa84 <_init>,
    fini=0x80b2ae0 <_fini>, rtld_fini=0x4000d3c4 <_dl_fini>, stack_end=0xbffff6dc) at ../sysdeps/generic/libc-start.c:129

system is running on:

php 4.2.3
Redhat Linux



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-24 03:58 UTC]
Please try using this CVS snapshot:
For Windows:

One more try. (I should have asked you to test the snapshot right away, sorry about that)

 [2003-02-24 06:17 UTC] m dot heidenwolf at ehotel dot ag

no problem, i tried the following Snaps 

all with the same result

make warnings like

/usr/local/src/new_022403/php4-STABLE-200302240630/ext/standard/var_unserializer.c:751: warning: label `yy80' defined but not used
/usr/local/src/new_022403/php4-STABLE-200302240630/ext/standard/var_unserializer.c:749: warning: label `yy79' defined but not used
/usr/local/src/new_022403/php4-STABLE-200302240630/ext/standard/var_unserializer.c:746: warning: label `yy78' defined but not used


ext/mysql/libmysql/my_tempnam.lo: In function `my_tempnam':
/usr/local/src/new_022403/php4-STABLE-200302240830/ext/mysql/libmysql/my_tempnam.c:103: the use of `tempnam' is dangerous, better use `mkstemp'

these i had also before at 4.3.1 but php works anyway
but finally at make install i got

make[1]: *** [install-pear-installer] Ung?ltiger Maschinenbefehl (Speicherauszug erstellt)

					invalid machine instruction (memory dump created)

i got the core file but i sadly dont know how to handle it

 [2003-02-24 06:40 UTC]
What configure line and compiler version are you using?

 [2003-02-24 06:58 UTC] m dot heidenwolf at ehotel dot ag
configure line:
CPPFLAGS='-I/usr/include/openssl -DEAPI' \
LDFLAGS='-L/usr/include/openssl' \
'./configure' \
'--with-oci8=/ora8/m01/app/oracle/product/8.1.7' \
'--disable-short-tags' \
'--enable-sockets' \
'--enable-ctype' \
'--with-apxs=/usr/local/apache/bin/apxs' \
'--with-curl' \
'--enable-sigchild' \
'--with-zlib' \
'--enable-bcmath' \
'--enable-debug' \

gcc 2.96

 [2003-02-24 07:29 UTC]

So please "upgrade" first to a working and official version
of gcc, like 2.95.3.

 [2003-02-24 09:28 UTC] m dot heidenwolf at ehotel dot ag

ok, another one...

configure line:
CPPFLAGS='-I/usr/include/openssl -DEAPI' \
LDFLAGS='-L/usr/include/openssl' \
'./configure' \
'--with-oci8=/ora8/m01/app/oracle/product/8.1.7' \
'--disable-short-tags' \
'--enable-sockets' \
'--enable-ctype' \
'--with-apxs=/usr/local/apache/bin/apxs' \
'--with-curl' \
'--enable-sigchild' \
'--with-zlib' \
'--enable-bcmath' \
'--enable-debug' \

gcc version:
gcc (GCC) 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

Redhat 8.0

Program received signal SIGSEGV, Segmentation fault.
0x4010a4a5 in memcpy () from /lib/
(gdb) bt
#0  0x4010a4a5 in memcpy () from /lib/
#1  0x4029246d in smart_str_appendl_ex (dest=0xbfff8290, src=0x8306f78 "?\232H\b\fo0\b??0\b?q0\b", len=1, what=0)
    at /tmp/php4-STABLE-200302241230/ext/standard/php_smart_str.h:76
#2  0x4029270e in php_var_serialize_class_name (buf=0xbfff8290, struc=0x8306f78)
    at /tmp/php4-STABLE-200302241230/ext/standard/var.c:420
#3  0x40291eeb in php_var_serialize_intern (buf=0xbfff8290, struc=0x8306f78, var_hash=0xbfff82a0)
    at /tmp/php4-STABLE-200302241230/ext/standard/var.c:560
#4  0x40292032 in php_var_serialize_intern (buf=0xbfff8290, struc=0x81ab484, var_hash=0xbfff82a0)
    at /tmp/php4-STABLE-200302241230/ext/standard/var.c:598
#5  0x40292095 in php_var_serialize (buf=0xbfff8290, struc=0x81ab484, var_hash=0xbfff82a0)
    at /tmp/php4-STABLE-200302241230/ext/standard/var.c:612
#6  0x40292144 in zif_serialize (ht=1, return_value=0x830af84, this_ptr=0x0, return_value_used=1)
    at /tmp/php4-STABLE-200302241230/ext/standard/var.c:635
#7  0x4030f426 in execute (op_array=0x8444e38) at /tmp/php4-STABLE-200302241230/Zend/zend_execute.c:1596
#8  0x4030f659 in execute (op_array=0x82f5444) at /tmp/php4-STABLE-200302241230/Zend/zend_execute.c:1640
#9  0x402fe121 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /tmp/php4-STABLE-200302241230/Zend/zend.c:864
#10 0x402c8cbb in php_execute_script (primary_file=0xbffff290) at /tmp/php4-STABLE-200302241230/main/main.c:1586
#11 0x40314322 in apache_php_module_main (r=0x8161cb4, display_source_mode=0)
    at /tmp/php4-STABLE-200302241230/sapi/apache/sapi_apache.c:55
#12 0x403152c6 in send_php (r=0x8161cb4, display_source_mode=0,
    filename=0x816397c "/home/httpd/html/fastbooking/bedhunter/de/buchung.php")
    at /tmp/php4-STABLE-200302241230/sapi/apache/mod_php4.c:617
#13 0x4031533f in send_parsed_php (r=0x8161cb4) at /tmp/php4-STABLE-200302241230/sapi/apache/mod_php4.c:632
#14 0x08083db8 in ap_invoke_handler ()
#15 0x08098262 in process_request_internal ()
#16 0x080982c2 in ap_process_request ()
#17 0x0808f686 in child_main ()
#18 0x0808f84c in make_child ()
#19 0x0808f9b3 in startup_children ()
#20 0x0808ffe0 in standalone_main ()
#21 0x08090818 in main ()
#22 0x400a3914 in __libc_start_main () from /lib/


 [2003-02-24 19:50 UTC] gbaratto at superb dot net
I'm on the same situation as marco:

./configure --prefix=/usr/local/php-4.3.1 --with-apxs2=/usr/local/apache-2.0.44/bin/apxs --with-mysql=/usr --with-pfpro=/usr/local --with-openssl

redhat 8
gcc 3.2
mysql 4.0.10-gamma
openssl-devel-0.9.6b-29 (yeah I know it is old, but redhat said they fixed the security bugs)
 [2003-02-25 02:23 UTC]
So now common for both is that you use GCC 3.2.
Try with 2.95.3 like I suggested earlier.

Also, if there is some script involved, it would be nice
to know what it is doing..

 [2003-03-09 18:58 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 06:01:29 2024 UTC