php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22349 W2K Server, Apache 2.0.44, FireBird 1.5 (IB6 clone)
Submitted: 2003-02-21 03:28 UTC Modified: 2003-08-16 10:34 UTC
From: nicon49nicon at mail dot ru Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.3.0 OS: W2K Server
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nicon49nicon at mail dot ru
New email:
PHP Version: OS:

 

 [2003-02-21 03:28 UTC] nicon49nicon at mail dot ru
Anythings work fine, but this:

$dbh = ibase_connect($DBAlias, $DBUser, $DBPassword,'WIN1251',0,3);
 if (is_null($dbh)):
     echo "FB error";
 else:
    echo "FB Ok";
 endif;

both: if $DBAlias - correct, or not i have "FB Ok";
also i try is_int(),pconnect,gettype, etc - without effect. 
In Apache's log i see correct line:
"PHP Warning:  ibase_connect(): I/O error for file "D:\ph1p_objects.gdb" Error while trying to open file The system cannot find the file specified..."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-21 03:31 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2003-02-26 10:46 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-08-16 10:34 UTC] abies@php.net
ibase_connect() returns (bool)false on failure, not null.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 22:01:24 2020 UTC