php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22333 Error in math operation
Submitted: 2003-02-20 08:26 UTC Modified: 2003-02-20 08:35 UTC
From: paulo at gruposim dot com dot br Assigned:
Status: Not a bug Package: Math related
PHP Version: 4.3.1 OS: Windows ME 4.90.3000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paulo at gruposim dot com dot br
New email:
PHP Version: OS:

 

 [2003-02-20 08:26 UTC] paulo at gruposim dot com dot br
<?
$x  = 0.7;
$x -= 0.3;
$x -= 0.4;
var_dump($x); // return float(-5.55111512313E-17) and not float(0) 
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-20 08:35 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Not a bug:

http://www.php.net/manual/en/language.types.float.php#AEN3375
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 14 15:01:23 2019 UTC