php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22305 Compile Fails - OpenSSL Related
Submitted: 2003-02-19 15:44 UTC Modified: 2003-02-25 19:18 UTC
From: dave at socrates dot thinkhost dot com Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.3.1 OS: FreeBSD 4.7-RELEASE-p2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dave at socrates dot thinkhost dot com
New email:
PHP Version: OS:

 

 [2003-02-19 15:44 UTC] dave at socrates dot thinkhost dot com
I just updated OpenSSL to 0.9.7a, and then after that I attempted to build the latest PHP-4.3.1. The configuration script completes without error, however, during the compile it dies in the following fatel error:

ext/openssl/openssl.lo: In function `zm_startup_openssl':
/usr/local/src/php-4.3.1/ext/openssl/openssl.c(.text+0xb69): undefined reference to `OPENSSL_add_all_algorithms_noconf'
*** Error code 1

Stop in /usr/local/src/php-4.3.1.

Any idea how to fix this?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-20 00:16 UTC] spam at digitalstreams dot net
This is also occuring on slackware 8.1 with openssl 0.9.7a!

ext/openssl/openssl.o: In function `zm_startup_openssl':
/root/apps/installed/ssl+php/php-4.3.1/ext/openssl/openssl.c:541: undefined reference to `OPENSSL_add_all_algorithms_noconf'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

This is against a 4.3.1 php.
 [2003-02-20 01:22 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Latest snapshot compiles just fine with OpenSSL 0.9.7..

 [2003-02-24 11:16 UTC] dave at socrates dot thinkhost dot com
Same problem:

ext/openssl/openssl.lo: In function `zm_startup_openssl':
/usr/local/src/php4-STABLE-200302241630/ext/openssl/openssl.c(.text+0xb69): undefined reference to `OPENSSL_add_all_algorithms_noconf'
*** Error code 1

Stop in /usr/local/src/php4-STABLE-200302241630.
 [2003-02-25 02:29 UTC] sniper@php.net
It's propably due to broken installation of openssl (and it's header files). Please remove all old remains of it
and reinstall the new version.

 [2003-02-25 18:27 UTC] dave at socrates dot thinkhost dot com
CVSup'ing the FreeBSD ports collection, and installing OpenSSL 0.9.7a from the ports collection fixed the problem.

OpenSSL was previously built from the source downloaded from the openssl.org website.
 [2003-02-25 19:18 UTC] magnus@php.net
Not a PHP problem => Bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 00:03:13 2021 UTC