php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22302 fsockopen() : php_network_getaddresses: getaddrinfo failed
Submitted: 2003-02-19 11:58 UTC Modified: 2003-02-21 05:16 UTC
From: admin at iut-info dot ens dot univ-reims dot fr Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.3.0 OS: HP-UX 11.11
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at iut-info dot ens dot univ-reims dot fr
New email:
PHP Version: OS:

 

 [2003-02-19 11:58 UTC] admin at iut-info dot ens dot univ-reims dot fr
The script :
-------------------
$nom="mail";
$adr=gethostbyname($nom);
echo "$nom=$adr<BR />";
$fp=fsockopen ($adr, 110, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br>\n";
} else {
    echo fgets ($fp,128) . "<BR />\n";
    fputs ($fp, "QUIT\r\n");
    echo fgets ($fp,128) . "<BR />\n";
    fclose ($fp);
    }

 ?>
----- Result (work's fine) ----------
mail=172.18.1.1
+OK POP3 iut-info v4.41 server ready
+OK Sayonara 
------ But if i try (other lines not changed) ------
$fp=fsockopen ($nom, 110, $errno, $errstr, 30);
----- Result ------------
mail=172.18.1.1

Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: host nor service provided, or not known in /home/prof/collet/public_html/testsock.php on line 14

Warning: fsockopen() [function.fsockopen]: unable to connect to mail:110 in /home/prof/collet/public_html/testsock.php on line 14
Protocol not supported (221)
-----------------------------------------------
From the doc, hostname could be a name, not only a IP.

----- PHP Compile with ---------------
./configure                             \
        --with-oci8                     \
        --with-apache=../apache_1.3.27  \
        --with-gd                       \
        --with-pdflib=/opt/pdflib       \
        --with-jpeg-dir                 \
        --with-png-dir                  \
        --with-tiff-dir                 \
        --with-zlib                     \
        --with-bz2                      \
        --enable-sigchild               \
        --with-mysql=/opt/mysql         \
        --with-pgsql=/opt/pgsql         \
        --with-tsrm-pthreads            \
        --with-dom                      \
        --enable-sockets
------------------------------
Cordialy.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-19 12:11 UTC] admin at iut-info dot ens dot univ-reims dot fr
No probleme with PHP 4.2.3 on the same server.

(PHP 4.2.3 is include in HP WebServer Suite,
distributed by HP, in binary format)
 [2003-02-19 20:25 UTC] wez@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Please try a snapshot.

 [2003-02-20 11:22 UTC] admin at iut-info dot ens dot univ-reims dot fr
I've downloaded php4-STABLE-200302201630

Compil/install Ok (on another port)

Same error.
 [2003-02-21 04:19 UTC] admin at iut-info dot ens dot univ-reims dot fr
After some search, i've found that the "getaddrinfo" function doesn't work under HP-UX 11.11 (ok for host
in the host file, ko for dns).

I apply 3 patch :
  PHCO_27740 libc cumulative patch
  PHCO_24402 libc cumulative header file patch
  PHNE_27796 libnss_dns DNS backend patch

And now the script works fine.

I give the info for the other HP-UX and PHP users.
I think you can close the bug.

Cordialy.
 [2003-02-21 05:16 UTC] wez@php.net
Not a bug in PHP, so marking as bogus.

Thanks for looking into this; we don't really have
any HP-UX resources ourselves.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 21:01:04 2020 UTC