|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22265 PHP fails to pass variables randomly
Submitted: 2003-02-18 02:02 UTC Modified: 2003-03-09 18:53 UTC
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: andy at thegartsidegroup dot com Assigned:
Status: No Feedback Package: IIS related
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
18 + 48 = ?
Subscribe to this entry?

 [2003-02-18 02:02 UTC] andy at thegartsidegroup dot com
PHP 4.3.0 was working fine on W2kSP3 and IIS5 with latest security rollup and with MySQL 3.23.50. It is a CGI installation.
Then I added a new user and changed some file permissions. These changes were very careful and I made sure that IUSR_mymachine had read and execute permissions to all required directories, as per the install.txt readme. My IIS 5 web-development environment went crazy. Sometimes it worked, sometimes it didn't. <? phpinfo(); ?> works fine as a test file. Sometimes I get a 404 message for files I know are there, other times I get a complete failure to retrieve variables from the database (but not the error message that I wrote if the DB connect failed) These files worked perfectly just a few days ago. It no longer seems to support sessions either. I spent days and days scouring the php sites, looking for a solution - nothing. I am quite an expert at php and IIS 5 configuration settings by now, so I have checked them repeatedly.
Eventually, I gave up. I repartitioned my hard-drive and re-installed Windows 2000 SP3. This time, I added all the users I needed and set the permissions before installing anything. I re-installed IIS and the rollup package. I re-installed MySQL and tested it extensively. I went and got the latest (4.3.1) php installer.exe and re-installed windows. SAME PROBLEM!!! I reset all the permissions on all directories, sub-directories and files on my entire machine to "full-control everyone" NO SUCCESS! Random failures, mostly to do with variables disappearing in forms or in queries to the databases.
I am desperate now. I NEED to do work, not chase this anymore. I'll see how this goes today USA time, then I'll have to try rebuilding AGAIN with no extra users and default file permissions. This is obviously not a very good solution.
Andrew Gartside
(Canberra Australia)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-18 23:33 UTC]
Please try using this CVS snapshot:
For Windows:

Some problems are fixed in the CVS which were not in 4.3.1..
So please give it a go.

Also, you said simple <?php phpinfo(); ?> script works 
always? If the snapshot doesn't help, can you try reducing
the problematic scripts to bare minimum which still causes
this? Try to see what is common to all of them.

 [2003-02-19 15:53 UTC] andy at thegartsidegroup dot com
I have since learned that I actually had two separate problems happening. One was entirely my own fault for not being up-to-date with PHP. The default setting for register_globals has changed since I learned php coding. I might point out that there is no mention of this in the install.txt that ships with the download. Anyway, I have learned something new and better coding and security practice. 

The original problem remains. I altered the permissions for a few directories (so that other users couldn't mess about with a few programs) and a working version of PHP4 stopped working. Mainly giving the error message "No input file specified" but also occasionally a 404 error. Changing the file permissions back didn't fix it. This is why I think there may be a bug. I note that I haven't found anyone who has this problem on the Internet who has managed to resolve it.

Sorry for the confusion in the first post. The re-install actually worked afterall.

 [2003-02-23 16:15 UTC] michael dot mauch at gmx dot de
php4-STABLE-200302232030 doesn't work here (Linux) as a CGI:

% echo '<?php echo "hi\n";?>' | sapi/cgi/php
Status: 404
Content-type: text/html
X-Powered-By: PHP/4.3.2-dev

No input file specified.

No safe_mode or open_base_dir in effect (just php.ini-dist or php.ini-recommended). php-4.3.1 works fine here.
 [2003-03-09 18:53 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 13:01:29 2024 UTC