php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #22264 Posting notes to the manual
Submitted: 2003-02-18 00:23 UTC Modified: 2004-10-24 13:32 UTC
From: wyvern at greywyvern dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.3.1 OS: XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wyvern at greywyvern dot com
New email:
PHP Version: OS:

 

 [2003-02-18 00:23 UTC] wyvern at greywyvern dot com
The wordwrap thingy when you try to post notes to the manual SUCKS!  I'm trying to post a LONG regexp to the preg_replace list and I cannot unless I break it up.  As you know, if you break up a regexp pattern, IT WILL NOT WORK.  And you know as well as I that there'll be lusers who won't understand to glue it back together before using it.

What's up with this?

Grey


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-18 06:23 UTC] goba@php.net
PHP has that cool string concatenation feature, don't you know? ;)

$regexp = "/\\w" .
          "+" .
          "$/";
 [2004-10-22 19:28 UTC] jmmolina at free dot fr
I tried to post a note and got the following error message :

? Your note contains a bit of text that will result in a line that is too long, even after using wordwrap(). ?

It seems the note I tried to post contains too long lines. It both contains text and a PHP script. You can get the note at http://jmmolina.free.fr/t_29327

I don't understand why the note system uses the wordwrap function. You need to word wrap text in a text based environment, not in a browser. The browser itself word wraps the text it displays.

So does the wordwrap function apply to the text or the script ? At least the error message should be updated to help users to correctly format their notes. Better the noting system should be able to reformat the code without displaying this error message.
 [2004-10-24 13:32 UTC] goba@php.net
jmmolina: we check whether lines are wrappable, because people *hate* to scroll horizontally. If your user note is not wrappable, then it will not get accepted. Too long commands without whitespace are not readable anyway.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jul 28 21:01:24 2021 UTC