php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22236 Libsablot compile error
Submitted: 2003-02-15 18:43 UTC Modified: 2003-03-03 16:27 UTC
From: shunter at venticon dot com Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.0 OS: Mandrake 9.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shunter at venticon dot com
New email:
PHP Version: OS:

 

 [2003-02-15 18:43 UTC] shunter at venticon dot com
OS:      Mandrake 9.0
Expat:   expat 1.95.2 & 1.95.6
Sablot:  Sablot 0.97
Libtool: 1.4.2
PHP:     php 4.3.0

Sablot config:
./configure 
--prefix=/usr/local/sablot --with-expat-prefix=/usr/local/expat

PHP config:
./configure \
--prefix=/usr/local/php \
--bindir=/usr/local/bin \
--with-apxs=/usr/local/apache/bin/apxs \
--with-config-file-path=/etc \
--with-zlib \
--with-dom \
--with-dom-xslt \
--with-gd \
--with-gettext \
--with-java=/usr/local/java \
--with-mysql \
--with-pgsql \
--with-regex=system \
--with-xslt-sablot=/usr/local/sablot \
--with-xml \
--enable-magic-quotes \
--enable-bcmath \
--enable-calendar \
--enable-dio \
--enable-exif \
--enable-shmop \
--enable-sockets \
--enable-sysvmsg \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx \
--enable-xslt


PHP Error:
/usr/local/sablot/lib/libsablot.so: undefined reference to `operator new[](unsigned)'
/usr/local/sablot/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/local/sablot/lib/libsablot.so: undefined reference to `operator delete(void*)'
/usr/local/sablot/lib/libsablot.so: undefined reference to `__gxx_personality_v0'
/usr/local/sablot/lib/libsablot.so: undefined reference to `__cxa_pure_virtual'
/usr/local/sablot/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/local/sablot/lib/libsablot.so: undefined reference to `operator delete[](void*)'
/usr/local/sablot/lib/libsablot.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/local/sablot/lib/libsablot.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

This error is generated durning the "make" process.
What can i do to fix this problem?

Thanks,

Ray

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-16 11:38 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


Try search before you submit any reports..

 [2003-02-16 13:03 UTC] shunter at venticon dot com
I hate to say it, but i have done a search and advanced search for the bug and i have not found one that is open.

Could you please specify the bug that you are referring too.

Thanks,

Ray
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 17:01:36 2019 UTC