php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22223 Register Globals config in php.ini get ignored
Submitted: 2003-02-14 07:30 UTC Modified: 2003-02-22 20:20 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: 0330 at bigfoot dot com Assigned:
Status: No Feedback Package: PHP options/info functions
PHP Version: 4.3.0 OS: Slackware Linux 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 0330 at bigfoot dot com
New email:
PHP Version: OS:

 

 [2003-02-14 07:30 UTC] 0330 at bigfoot dot com
In my /etc/php.ini of 4.3.0,
register_globals = On

In <? phpinfo(); ?>,
it said,
register_globals =
Off
Off

I am using the followings options in complie:
'./configure' '--with-mysql' '--with-apache=../ apache_1.3.27' '--with-config-file-path=/etc --disable-cli'




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-14 09:03 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

If the problem persists include the output of 
strace sapi/cli/php -h 2>&1 | grep "open(.*\.ini"

in your reply.
 [2003-02-22 20:20 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 06:01:29 2024 UTC