php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22195 array_reduce of single-element array returns nothing
Submitted: 2003-02-12 18:38 UTC Modified: 2003-02-12 18:45 UTC
From: joergland at debian dot org Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 4.2.3 OS: Debian GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joergland at debian dot org
New email:
PHP Version: OS:

 

 [2003-02-12 18:38 UTC] joergland at debian dot org
sample code:

$foo = array('a');
function r($a, $b) { return $a . $b; }
$str = array_reduce($foo, 'r');

$str is empty after execution, should be 'a'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-12 18:40 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

This works fine with PHP 4.3.1-dev, propably works
with PHP 4.3.0 too.

 [2003-02-12 18:45 UTC] joergland at debian dot org
sorry, my fault, i reported to fast ;-/
that's actually not a bug in PHP but in my brain

Joerg
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 10:01:23 2020 UTC