php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22193 PHP no longer supports Cybercash?!?
Submitted: 2003-02-12 18:08 UTC Modified: 2003-02-13 11:33 UTC
From: kirk at strauser dot com Assigned:
Status: Closed Package: *E-commerce functions
PHP Version: 4.3.0 OS: FreeBSD 4.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 - 29 = ?
Subscribe to this entry?

 
 [2003-02-12 18:08 UTC] kirk at strauser dot com
PHP-4.3.0 no longer supports Cybercash.  This came as an unpleasant surprise to a web hosting firm I work with, and their customers who still use Cybercash (which will continue to be supported by Verisign, according to Verisign's "Cybercash FAQ").

I have to say, this was a real kick in the teeth.  Before deleting features because of supposed obsolescence, please verify that the feature really is dead.  As it stands, everyone who depends on this now-gone module for their livelihood is in for a bit of a shock when they next upgrade their servers.

Repeat: Cybercash is still very much alive and supported.

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-12 18:35 UTC] sniper@php.net
You can find the extension in PECl, if you really need it.
It was not deleted..

And you're free to read the NEWS file before upgrading.
There's no need to upgrade to PHP 4.3 if your existing
installation works...(basic rule of system administration)

 [2003-02-12 21:04 UTC] kirk at strauser dot com
> You can find the extension in PECl, if you really need it.
> It was not deleted..

From NEWS:


- Removed extensions: (Jan, Jani, Sebastian)
  . ext/aspell
  . ext/ccvs
  . ext/cybercash
  . ext/icap
  . sapi/fastcgi
  . sapi/fhttpd
- Moved extensions to PECL (http://pear.php.net/): (James, Derick)
  . ext/vpopmail
  . ext/cybermut

Cybercash is listed among the "removed" modules as opposed to the "Moved extensions to PECL".  Furthermore, it doesn't appear in the Pear :: Package search page.

> And you're free to read the NEWS file before upgrading.

It was part of an automatic upgrade.

> There's no need to upgrade to PHP 4.3 if your existing
>installation works...(basic rule of system administration)

As 4.3.0 is the version that builds against FreeBSD's port of PostgreSQL 7.3.2, and we were upgrading the database to fix other problems, I guess you could say that the existing installation did not work.

This package should be put back into the base system or made available via PEAR (it doesn't seem to be now) until the Cybercash system truly is obsoleted.
 [2003-02-12 21:25 UTC] nicos@php.net
Yes it's not in PEAR/PECL. It has been removed because we thought nobody uses it. Since we will probably not put it back  you are free to copy ext/cybercash from php-4.2.3 into php-4.3.0 and to cd php-4.3.0 ; ./buildconf so you will have it back in your configure line.

(Note that Jani mentioned PEAR because he thought we were talking about cybermut and not cybercash).
 [2003-02-12 21:25 UTC] sniper@php.net
It will not come back, it's deprecated. If you _really_ need it, take it from 4.2.3.

 [2003-02-12 21:37 UTC] kirk at strauser dot com
Thanks for the information.  I still believe that it was deprecated unfairly (it still interfaces with an operating, maintained service), but that's your call.
 [2003-02-12 21:41 UTC] nicos@php.net
Interesting, can you point any URI saying that their services are still up and maintained?

We are open-minded !  :-)
 [2003-02-12 22:14 UTC] kirk at strauser dot com
From http://www.verisign.com/support/cyberCash/integration.html (selected excerpts):

------------------------------

1. Will my service be interrupted?

* No, we will continue to operate the CyberCash gateway at its high level of reliability and uptime.

3. Do I need to convert over to VeriSign's gateway?

* No, we will continue to operate the CyberCash gateway for the foreseeable future.

8. I looked at VeriSign before going with CyberCash and didn't care for their product offering. Should I be looking at other providers now?

* We are maintaining the service for existing CyberCash customers, so there is no reason for you to think about looking at other payment gateways.

------------------------------

I also submit as evidence the fact that the server's I'm dealing with have cleared several thousand transactions via PHP and Cybercash already this month.  :)
 [2003-02-12 22:55 UTC] gschlossnagle@php.net
Moved cybercash into PECL.  You SHOULD be able to just do a 
pear install cybercash, but seeing as I dont have the 
cybercash libraries that need to be linked against, your 
mileage may vary.
 [2003-02-13 10:30 UTC] kirk at strauser dot com
Thanks!  That solves the problem handily.
 [2003-02-13 11:33 UTC] philip@php.net
The documentation at php.net/cybercash has been updated to reflect this change.  The docs have linked to the above quoted faq for quite some time.

The new documentation will show up online within the coming week(s).
 [2023-08-05 11:29 UTC] yn0uk5r84 at mozmail dot com
The following pull request has been associated:

Patch Name: fix for PHP 8
On GitHub:  https://github.com/php/pecl-text-ssdeep/pull/2
Patch:      https://github.com/php/pecl-text-ssdeep/pull/2.patch
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 18 20:01:34 2024 UTC