php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22164 $_GET decodes URL encoding incorrectly
Submitted: 2003-02-11 05:38 UTC Modified: 2003-02-11 06:21 UTC
From: arachnid at notdot dot net Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.2.3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: arachnid at notdot dot net
New email:
PHP Version: OS:

 

 [2003-02-11 05:38 UTC] arachnid at notdot dot net
When calling a script with a parameter such as "script.php?test=%5C" (5C is ASCII for '\'), $_GET['test'] incorrectly returns '\\' instead of '\'.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-11 05:42 UTC] arachnid at notdot dot net
urldecode("%5c") correctly returns "\".
 [2003-02-11 06:21 UTC] moriyoshi@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


magic_quotes_gpc.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 01:03:38 2021 UTC