php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22143 Lag
Submitted: 2003-02-09 22:24 UTC Modified: 2003-02-11 15:18 UTC
Votes:5
Avg. Score:4.2 ± 1.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:2 (50.0%)
From: markbradley8 at hotmail dot com Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.3.0 OS: RedHat 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: markbradley8 at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-02-09 22:24 UTC] markbradley8 at hotmail dot com
Whenever I enable zlib, I experience a huge lag when loading the page, even within my 100mbps home network. As soon as I turn off zlib, it all loads fast again. I notice this mostly on an application that uses mySQL 3.23.55

'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql' '--with-zlib' 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-10 09:50 UTC] iliaa@php.net
Are you using zlib compression for your webpages?
 [2003-02-10 15:28 UTC] markbradley8 at hotmail dot com
Yes. I have it enabled on php.ini
 [2003-02-11 01:03 UTC] markbradley8 at hotmail dot com
Just to note, I only get this when I change zlib.output_compression from Off to On.

It apparently does send the compression headers, but it takes a long while to load. I do not notice any sort of server load spike during this time either.

Could this only be a problem with a certain php.ini setting?
 [2003-02-11 10:37 UTC] iliaa@php.net
As unlikely as it may sound this may be a browser issue. Before going further, try to see if the issue is particular to a certain browser or if it can be replicated with any browser.
Beyond using zlib compression are you using any ob_* buffering code inside your scripts?
 [2003-02-11 14:59 UTC] markbradley8 at hotmail dot com
Yes, it seems to be browser related. It doesn't seem to affect MSIE 5 on Windows 2000 but it affects the latest MSIE 6 on XP. It might be related to one of their recent patches.

Thanks.
 [2003-02-11 15:18 UTC] iliaa@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

Apparently this is a browser bug as such it is not something PHP developers can fix, marking bogus.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 05:01:25 2020 UTC