php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21977 ./configure --with-interbase (or with --with-enable-all) broken
Submitted: 2003-01-31 04:40 UTC Modified: 2003-02-03 05:46 UTC
From: amd at tt dot ee Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4CVS-2003-01-31 (stable) OS: Gentoo/Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: amd at tt dot ee
New email:
PHP Version: OS:

 

 [2003-01-31 04:40 UTC] amd at tt dot ee
I don't have interbase on my machine.
./configure --with-interbase |grep -i interbase
checking for InterBase support... yes

from config.log:
configure:46431: gcc -o conftest -g -O2   -Wl,-rpath,/usr/interbase/lib -L/usr/interbase/lib conftest.c -lgds -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt 1>&5
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgds
collect2: ld returned 1 exit status
configure: failed program was:
#line 46420 "configure"
#include "confdefs.h"
#include <stdio.h>
int main()
{
  FILE *f=fopen("conftestval", "w");
  if (!f) return(1);
  fprintf(f, "%d\n", sizeof(char));
  return(0);
}
libgds is interbase library...
when running --with-enable-all
it brakes also ming support (config.log):

configure:43734: checking for Ming_useSWFVersion in -lming
configure:43753: gcc -o conftest -g -O2  
    -L/usr/lib
    -Wl,-rpath,/usr/interbase/lib -L/usr/interbase/lib -Wl,-rpath,/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386/server -L/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386/server -Wl,-rpath,/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386/native_threads -L/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386/native_threads -Wl,-rpath,/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386 -L/opt/blackdown-jdk-1.4.1_beta/jre/lib/i386 conftest.c -lming  -lm -lmhash -ljava -lgds -lcrypt -lpam -lgmp -lpng -lz -lz -lbz2 -lz -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt -lxml2 -lz -lm 1>&5
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgds 
collect2: ld returned 1 exit status
configure: failed program was:                                                  
#line 43742 "configure"
#include "confdefs.h"              
/* Override any gcc2 internal prototype to avoid an error.  */                  /* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char Ming_useSWFVersion();

int main() {
Ming_useSWFVersion()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-31 04:47 UTC] sniper@php.net
If you don't have something, use '--without-interbase' for example.

--enable-all is not really useful, it's just a side-effect
of adding --disable-all, which IS useful.

This _IS_NOT_BUG_. Please stop submitting bug reports about
this already..

 [2003-01-31 04:50 UTC] amd at tt dot ee
but when i enable something, then configure should also check if it exists.
 [2003-02-03 05:46 UTC] sniper@php.net
I've added a test for it now in CVS.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 13:01:27 2020 UTC