php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21946 Trying to create COM object - Apache crash
Submitted: 2003-01-29 11:33 UTC Modified: 2003-01-31 19:10 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: dominik dot lebar at ensico dot si Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.0 OS: Windows NT 4.0, Service pack 6a
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dominik dot lebar at ensico dot si
New email:
PHP Version: OS:

 

 [2003-01-29 11:33 UTC] dominik dot lebar at ensico dot si
When I try to invoke 
  $Q = new COM("ixsso.Query"); 
apache crashes. It's a component of the Microsoft Index Server and this works fine under IIS and ASP pages. I tried to use 2.0.43 and 2.0.44. Same on both of them.

Best regards,
  Dominik

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-29 11:34 UTC] dominik dot lebar at ensico dot si
Forgot to mention that 2.0.43 and 2.0.44 are apache versions.

Best regards,
  Dominik
 [2003-01-29 12:12 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2003-01-29 14:58 UTC] dominik dot lebar at ensico dot si
I'm trying to write a search form using PHP Version 4.3.0, Apache version 2.0.44, Windows NT 4.0 with service pack 6 and Microsoft Index Server 2.0. I used example from IISSamples - ASP (query.asp). ASP example works fine on IIS 4.0 - I use Index Server for indexing Word and PDF documents and is essential part of my intranet. After submiting a form (using POST method),  page calls itself and retrieves a search string. The first and only line after it causes Apache to crash. The line is Index Server COM object creation using line :
  $Q = new COM("ixsso.Query");    
  $Util = new COM("ixsso.Util");
I have commented everything bellow including the second line and crash is reproducible.

Hope enough information was provided.

Best regards,
  Dominik
 [2003-01-29 15:03 UTC] dominik dot lebar at ensico dot si
Original lines from ASP :
    Q    = Server.CreateObject("ixsso.Query");
    util = Server.CreateObject("ixsso.Util");
    Q.Query = "test";
    Q.Columns = "DocTitle, Vpath, filename, size, write, characterization, rank, path, DocSubject, DocKeywords";
    RS = Q.CreateRecordSet("nonsequential");

but as I said I have commented all the lines after first line. I have read in some forum that someone did succeed to integrate PHP with Microsoft Index Server.
 
Best regards,
  Dominik
 [2003-01-30 01:42 UTC] major dot tom at sasktel dot net
I had this same issue on Win2k Pro running Apache 3.1.26.

I have other php scripts that were running fine. Only the one with COM was blowing up.

<event_log>
Application popup: Apache.exe - Application Error : The instruction at "0x10030727" referenced memory at "0x04243b30". The memory could not be "read".
</event_log>

The latest stable release solved my issue. Thanks!
 [2003-01-30 03:37 UTC] dominik dot lebar at ensico dot si
The latest stable did not solved my issue. The error is :

The instruction at "0x007205f9" refrenced memory at "0x5e3019c0". The memory
could not be "read".

Best regards,
 Dominik
 [2003-01-30 08:55 UTC] dominik dot lebar at ensico dot si
I managed to do it using ActivePerl - working fine.

Best regards,
  Dominik
 [2003-01-31 19:10 UTC] phanto@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

and fixed in cvs !

Read the instructions at http://bugs.php.net/how-to-report.php before filing a bugreport or i'll let the crazy finn loose :)

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 07:04:13 2022 UTC