php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21930 TO NAME not work
Submitted: 2003-01-29 00:31 UTC Modified: 2003-02-02 04:02 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: albaity at php4web dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.0 OS: Windows 2000 Proffiessional
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: albaity at php4web dot com
New email:
PHP Version: OS:

 

 [2003-01-29 00:31 UTC] albaity at php4web dot com
I take details from :
http://www.php.net/manual/en/function.mail.php

because it happen with me also

the smtp server with iis5 does not support a TO NAME,
you can send it to an email but not along with a name.
to say $to = "Miki <Miki@email.com>"; would not be accepted and you will get an error 501 Invalid address.
if you see this error, just try NOT sending emails with a TO name, only the email should be entered

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-29 00:33 UTC] albaity at php4web dot com
I want to comment that I USE the ISP SMTP , not IIS SMTP
and also not work..
 [2003-01-29 01:06 UTC] sniper@php.net
Please add a short example script here which clearly shows
your problem.

 [2003-01-29 01:57 UTC] albaity at php4web dot com
<?
function SendHtmlMsg($To,$From,$Sendername,$Receivername,$subject,$msg){
	mail($To, $subject, $msg,
	     "To: $Receivername <$To>\n" .
		 "From: $Sendername <$From>\n" .     
		 "X-Mailer: PHP 4.3\n".
		 "MIME-Version: 1.0\n" .
		 "Content-type: text/html; charset=-1256");
}
			 $From="info@site.com";
			 $Sendername = "Person";
			 $To = "albaity@php.net";
			 $Receivername = "Test Person";
			 $subject ="Test";
			 $msg = "Test<br/>Test";
SendHtmlMsg($To,$From,$Sendername,$Receivername,$subject,$msg);
?>
 [2003-01-29 06:06 UTC] sniper@php.net
PLEASE don't use the 'Add comment' link!!!
It's your own report, use the 'Edit submission' ALWAYS.

Anyway, this works fine for me:

mail('"someone somehwere" <someone@somewhere.com>', 'subject', 'message');


 [2003-01-29 06:31 UTC] albaity at php4web dot com
I take details from :
http://www.php.net/manual/en/function.mail.php

because it happen with me also

the smtp server with iis5 does not support a TO NAME,
you can send it to an email but not along with a name.
to say $to = "Miki <Miki@email.com>"; would not be accepted and you will
get an error 501 Invalid address.
if you see this error, just try NOT sending emails with a TO name, only
the email should be entered

That is given to me..
SMTP server response: 550 5.1.1 ... User unknown in C:\Projects\fnoon\functions.php on 138
I want to comment that I USE the ISP SMTP , not IIS SMTP
and also not work..

Now I think I understand what the problem ..
THAT BECAUSE I USE ARABIC EMAIL FORMAT ..
SORRY FOR MAKE NOISE AND VERY THMKS TO YOU SNIPER :P
 [2003-01-29 06:31 UTC] albaity at php4web dot com
I take details from :
http://www.php.net/manual/en/function.mail.php

because it happen with me also

the smtp server with iis5 does not support a TO NAME,
you can send it to an email but not along with a name.
to say $to = "Miki <Miki@email.com>"; would not be accepted and you will
get an error 501 Invalid address.
if you see this error, just try NOT sending emails with a TO name, only
the email should be entered

That is given to me..
SMTP server response: 550 5.1.1 ... User unknown in C:\Projects\fnoon\functions.php on 138
I want to comment that I USE the ISP SMTP , not IIS SMTP
and also not work..

Now I think I understand what the problem ..
THAT BECAUSE I USE ARABIC EMAIL FORMAT ..
SORRY FOR MAKE NOISE AND VERY THMKS TO YOU SNIPER :P
 [2003-01-29 06:49 UTC] sniper@php.net
So does it work when it's send as part of the headers?

 [2003-02-01 05:12 UTC] albaity at php4web dot com
I do not understand your Q
 [2003-02-01 10:49 UTC] sniper@php.net
Does this work:

<?php 
mail('', 'subject', 'message', "To: \"Some Name\" <someone@somehwere.com>"); 
?>

 [2003-02-02 00:09 UTC] albaity at php4web dot com
its work , but the problem was if the name \"Some Name\"
writed in arabic or chinese it will not work 
thats is the probelm
 [2003-02-02 00:09 UTC] albaity at php4web dot com
its work , but the problem was if the name \"Some Name\"
writed in arabic or chinese it will not work 
thats is the probelm
 [2003-02-02 00:34 UTC] albaity at php4web dot com
sorry its work , the bug is from me 
sorry for noise again
 [2003-02-02 04:02 UTC] sniper@php.net
Not a bug in PHP -> bogus.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 19:03:44 2023 UTC