php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21926 Apache process hangs
Submitted: 2003-01-28 13:16 UTC Modified: 2003-10-31 08:08 UTC
Votes:5
Avg. Score:4.4 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:1 (25.0%)
From: arinto at almedina dot net Assigned:
Status: Wont fix Package: Java related
PHP Version: 4CVS-2003-01-28 (stable) OS: Red Hat Linux 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: arinto at almedina dot net
New email:
PHP Version: OS:

 

 [2003-01-28 13:16 UTC] arinto at almedina dot net
Hi.

I'm using the PHP Java extension to run Jakarta Lucene to power my internal site search. Whenever I call a Java object, Apache starts between 1 to 5 new httpd processes and it keeps growing with each subsequent call to the object.
After some time (and after more than 50 httpd processes are started) the web site stops respondig for some clients. For others it continues running as usual.
This happens with PHP 4.3.0 and the latest CVS (2003-01-28)

My configure line is as follows:

'./configure' '--with-mysql' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-apxs=/var/www/bin/apxs' '--enable-xslt' '--with-xslt-sablot' '--with-xml' '--with-iconv' '--with-pgsql' '--with-dom' '--with-zlib' '--with-gd' '--with-java=/usr/java/j2sdk1.4.1_01' 

Java Version: Sun J2SE 1.4.1
Apache Version 1.3.24

This also seems to be the same bug as #20270, that is closed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-31 08:08 UTC] sniper@php.net
Java support in PHP 4 was experimental to begin with and will not be fixed. PHP 5 might have better support.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 12:01:36 2019 UTC