php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #219 1 bug while configuring php, and 1 bug configuring Apache.
Submitted: 1998-03-31 09:37 UTC Modified: 1998-03-31 11:37 UTC
From: chrisvik at tapir dot no Assigned: rasmus (profile)
Status: Closed Package: Compile Failure
PHP Version: 3.0 Latest CVS OS: RH5, kernel 2.1.91, Autoconf 2.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chrisvik at tapir dot no
New email:
PHP Version: OS:

 

 [1998-03-31 09:37 UTC] chrisvik at tapir dot no
I got the latest php3 source tree from Stig Bakken, 
executed autoconf, and typed the following command:

./configure --with-apache=/usr/src/apache_1.3b5 --with-msql=/local/www/Hughes --with-config-file-path=/local/www/sys/apache/conf --disable-debug --enable-safe-mode --enable-debugger

It all went well until "make install" where I got the error:

cp mod_php3.ch No such file or directory

I edited Makefile line:

INSTALL_IT = cp libmodphp3.a mod_php3.ch  ..etc....

to .[ch] and installation proceeded.


Then: configured apache 1.3b5 and it made a Makefile in modules/php3
but while compiling, the following error message occoured:

make: *** No rule to make target `libphp3.', needed by `lib'.  Stop.

I noticed that the variable LIBEXT wasn't set.. I added the line:

LIBEXT=a

to modules/php3/Makefile and installation succeeded.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-31 11:37 UTC] rasmus
Fixed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 08:01:24 2021 UTC