php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21850 PHP_AUTH_* unavaliable
Submitted: 2003-01-23 17:46 UTC Modified: 2003-01-24 06:13 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: xoomz at terra dot com dot br Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.3.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: xoomz at terra dot com dot br
New email:
PHP Version: OS:

 

 [2003-01-23 17:46 UTC] xoomz at terra dot com dot br
Philib disable PHP_AUTH_* on PHP 4.3.x to PHP 5, this is a problem in many cases, howto phpmyadmin use apache auth basic... :)

Have another solution?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-23 20:15 UTC] philip@php.net
It was decided to disable PHP_AUTH_* variables when safe_mode was enabled.  You can use REMOTE_USER for the username regardless.  Am marking this bug as bogus.

http://www.php.net/features.http-auth

p.s. I just tried phpmyadmin in safe mode with http auth and it works fine.
 [2003-01-24 06:13 UTC] xoomz at terra dot com dot br
but don't work with Apache auth method (.htpasswd) because haven't user auth passwd :)

thank your help
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Aug 01 08:01:24 2021 UTC