php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21765 ?> is not hidden by // comment
Submitted: 2003-01-20 03:07 UTC Modified: 2003-01-20 03:09 UTC
From: mattb at columbia dot edu Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.3.0 OS: RedHat 7.3, current updates
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mattb at columbia dot edu
New email:
PHP Version: OS:

 

 [2003-01-20 03:07 UTC] mattb at columbia dot edu
Try the following at a shell prompt:

% cat <<EOF | php
=====
<?php
//echo '?>';
?>
=====
EOF

The output will be:

=====
';
?>
=====

It looks like the parser is picking up the adjacent '?' and '>' characters inside the single quotes in the echo statement after they've been commented out using '//'.

I'm willing to bet 10-to-1 this is not the correct or desired behavior.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-20 03:08 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 17:05:44 2022 UTC