php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21752 mail() function lost
Submitted: 2003-01-19 11:12 UTC Modified: 2003-01-19 18:29 UTC
From: ciano at borgosatollo dot it Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.0 OS: Linux Mandrake 9.0 kernel 2.4.19
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ciano at borgosatollo dot it
New email:
PHP Version: OS:

 

 [2003-01-19 11:12 UTC] ciano at borgosatollo dot it
I'm using the mail() function as I used to do in the older versions but what I'm getting is an error =((.

script:
<?php
mail("foo@mail.org","prova","prova da legolas");
?>

error: Fatal error: Call to undefined function: mail() in /var/www/html/mail.php on line 2

this happens only with php 4.3.0, I read the changelog and ther was nothing reguarding this.

thx for help

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-19 18:12 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Your php lacks the mail() function because during installation (configure phase) PHP was unable to fund sendmail or equivalent binary on your system.
 [2003-01-19 18:29 UTC] ciano at borgosatollo dot it
Thx, that solved my problem =)))
sorry for my lack of attention :D
 [2003-03-13 21:01 UTC] fred at fred dot fred
I followed your link to the manual and found this: 



XLIX. Mail functions
Introduction
The mail() function allows you to send mail. 

Requirements
No external libraries are needed to build this extension.

Installation
There is no installation needed to use these functions; they are part of the PHP core.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC