php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21695 CLI Return codes not working properly
Submitted: 2003-01-16 15:13 UTC Modified: 2003-05-24 09:14 UTC
From: john@php.net Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.3.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john@php.net
New email:
PHP Version: OS:

 

 [2003-01-16 15:13 UTC] john@php.net
This very well may be a problem with Windows XP instead of PHP... but if nothing else it should be documented:

<?php
   system("C:\\PHP\\cli\\php -r 'exit(1);'", $retval);

   echo "$retval\n";
?>

On redhat, (of course, replacing the system call to the linux version of php-cli) this script echo's the return value as '1' which is the expected behavior. 

However, this same script ran in windows produces does not. Instead, it seems to be always return 254 regardless of the exit code. 

Please note that the above script has only been provided as an example of the problem -- it has been confirmed that system() and the -r argument are not causing this issue.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-24 09:14 UTC] helly@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Fixed in 4.3.2
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 21:01:29 2024 UTC