php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21691 PEAR::File_Find result warnings
Submitted: 2003-01-16 12:17 UTC Modified: 2003-02-14 05:07 UTC
From: sazonenkov at yandex dot ru Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.3.0 OS: winXp
Private report: No CVE-ID:
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sazonenkov at yandex dot ru
New email:
PHP Version: OS:

 

 [2003-01-16 12:17 UTC] sazonenkov at yandex dot ru
<?php
require_once 'File/Find.php';
print_r(File_find::maptree ('/'));
?>

<?php
require_once 'File/Find.php';
$ff = new File_Find();
$ff->maptree ('/'));
?>

Warning: Problem with method call - please report this bug in /usr/share/pear/File/Find.php on line 112

is it PEAR or PHP problem?

PEAR(v4.2.3 - not included in php4.3.0-win32)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-16 15:22 UTC] tularis@php.net
looks like PEAR to me...
 [2003-02-14 05:07 UTC] mj@php.net
File_Find cannot be called statically, like you did in line 3 of your script.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC