php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21652 ibase connect and trans error
Submitted: 2003-01-15 03:10 UTC Modified: 2003-08-27 17:20 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: kepesk at peto dot hu Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.3.0 OS: winxp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kepesk at peto dot hu
New email:
PHP Version: OS:

 

 [2003-01-15 03:10 UTC] kepesk at peto dot hu
When I use pconnect, and I open an db, and second I try to open an db with invalid path, the php is make general prot. fault, an it is exit without an error.

When I make transaction, and I commit it, and I try to rollback the committed tr, the php is make GPF, and it is exit without an error.

$tr=ibase_trans($db,...);
ibase_commit($tr);
...
ibase_rollback($tr); !!!!!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-10 21:35 UTC] daniela@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

If you are still able to reproduce this bug
could you post a little example? (max 10 lines of code)

 [2003-05-15 17:49 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-08-27 17:20 UTC] abies@php.net
First of all, you can't rollback a committed transaction. 

This bug is probably related to #7014 (errors returned by the Interbase API were stored in a buffer that had already been freed, causing a segfault) This has been fixed in 4.3.3.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 02:03:41 2022 UTC